]> Git — Sourcephile - haskell/symantic-compta.git/blob - default.nix
init
[haskell/symantic-compta.git] / default.nix
1 { pkgs ? import <nixpkgs> {}
2 , ghc ? null
3 , withHoogle ? false
4 }:
5 let
6 haskellPackages =
7 if ghc == null
8 then pkgs.haskellPackages
9 else pkgs.haskell.packages.${ghc};
10 hs = haskellPackages.extend (with pkgs.haskell.lib; hself: hsuper:
11 {
12 symantic-compta = buildFromSdist (hself.callCabal2nix "symantic-compta" ./. {});
13 symantic-document = buildFromSdist (hself.callCabal2nix "symantic-document"
14 (pkgs.fetchgit {
15 url = "git://git.sourcephile.fr/haskell/symantic-document.git";
16 rev = "refs/heads/master";
17 sha256 = "sha256-h2mzSKDWNSFs879qE8kma0z1vgWA32LWERRf9I+PqmE=";
18 }) {});
19 }
20 );
21 in hs.symantic-compta // {
22 shell = hs.shellFor {
23 #doBenchmark = true;
24 packages = p: [ p.symantic-compta ];
25 nativeBuildInputs = [
26 hs.cabal-install
27 hs.ghcid
28 hs.haskell-language-server
29 ];
30 buildInputs = [
31 ];
32 inherit withHoogle;
33 };
34 }