]> Git — Sourcephile - julm/air-duino.git/blob - shell.nix
update, using nix
[julm/air-duino.git] / shell.nix
1 { inputs, pkgs, ... }:
2 pkgs.mkShell {
3 name = "air-duino";
4 src = null;
5 #preferLocalBuild = true;
6 #allowSubstitutes = false;
7 buildInputs = with pkgs; [
8 arduino
9 arduino-core
10 arduino-mk
11 gcc
12 gcc-arm-embedded
13 avrdude
14 ];
15 #enableParallelBuilding = true;
16
17 ARDUINO = pkgs.arduino;
18 ARDUINO_PATH = pkgs.arduino-core;
19 ARDUINO_DIR = pkgs.arduino-core + "/share/arduino";
20 ARDMK_DIR = pkgs.arduino-mk;
21 AVR_TOOLS_DIR = pkgs.arduino + "/share/arduino/hardware/tools/avr";
22 USER_LIB_PATH = toString ./. + "/libraries";
23
24 #PATH="${pkgs.arduino + "/share/arduino/hardware/tools/avr/bin"}:$PATH"
25 shellHook = ''
26 '';
27 }