1 { config, pkgs, lib, inputs, private, hostName, ... }:
3 inherit (config.users) users;
4 inherit (config.services) davfs2;
8 ../profiles/dnscrypt-proxy2.nix
9 ../profiles/security.nix
10 ../networking/wireguard/wg-intra.nix
17 home-manager.users.julm = {
20 inputs.nix-doom-emacs.hmModule
22 host.hardware = ["ThinkPad" "X201"];
24 systemd.services.home-manager-julm.postStart = ''
25 ${pkgs.nix}/bin/nix-env --delete-generations +1 --profile /nix/var/nix/profiles/per-user/julm/home-manager
27 security.lockKernelModules = false;
28 users.mutableUsers = false;
32 # Put the hashedPassword in /nix/store, but it will also be in /etc/passwd
33 # which is already world readable.
34 hashedPassword = lib.readFile ../private/world/julm/hashedPassword;
47 # If created, zfs-mount.service would require:
48 # zfs set overlay=yes ${hostName}/home
54 secret-key-files = ${private}/${hostName}/nix/binary-cache/priv.pem
56 autoOptimiseStore = true;
60 options = "--delete-older-than 7d";
63 "nixpkgs=/etc/nixpkgs"
64 "nixpkgs-overlays=/etc/nixpkgs-overlays/overlays.nix"
66 trustedUsers = [ users.julm.name ];
67 binaryCaches = [ "http://nix-localcache.losurdo.wg" ];
68 binaryCachePublicKeys = [ "losurdo.sourcephile.fr-1:XGeaIE2AA2mZskSZ5bIDrfx53q+TDDWJOUEpZDX7los=" ];
80 keys = [ (lib.readFile ../private/world/julm/losurdo/ssh.pub) ];
82 users.users.julm.openssh.authorizedKeys.keys = [
83 (lib.readFile ../private/world/julm/losurdo/ssh.pub)
85 services.openssh.openFirewall = false;
86 services.openssh.forwardX11 = true;
87 services.openssh.passwordAuthentication = false;
89 nixpkgs.config.allowUnfree = true;
90 environment.etc."nixpkgs".source = pkgs.path;
91 environment.etc."nixpkgs-overlays".source = inputs.self + "/nixpkgs";
93 time.timeZone = "Europe/Paris";
94 i18n.defaultLocale = "fr_FR.UTF-8";
95 console.font = "Lat2-Terminus16";
96 console.keyMap = "fr";
100 domain = "localdomain";
101 search = [ "sourcephile.fr" ];
108 #backend = "wpa_supplicant";
119 hardware.pulseaudio.enable = true;
120 hardware.sane.enable = true;
121 hardware.sane.extraBackends = [ pkgs.hplipWithPlugin ];
123 environment.variables = {
126 SYSTEMD_LESS = "FKMRX";
128 environment.systemPackages = [
132 (pkgs.libsForQt5.callPackage
134 url = "https://raw.githubusercontent.com/ju1m/nixpkgs/bitmask/pkgs/tools/networking/bitmask-vpn/default.nix";
135 hash = "sha256-j9S+7GHrHF9sP5V/jtRai9v5OzxkxC0/chQDDc03+5A=";
136 #hash = lib.fakeHash;
138 { provider = "riseup" /* or "calyx" */; })
145 interactiveShellInit = ''
146 bind '"\e[A":history-search-backward'
147 bind '"\e[B":history-search-forward'
149 # Ignore duplicate commands, ignore commands starting with a space
150 export HISTCONTROL=erasedups:ignorespace
151 export HISTSIZE=42000
152 # Append to the history instead of overwriting (good for multiple connections)
156 mkcd () { mkdir -p "$1"; cd "$1"; }
159 then sudo tee /proc/acpi/ibm/fan <<<"level $1"
160 else grep '^\(level\|speed\):' /proc/acpi/ibm/fan
167 grep = "grep --color";
170 ls = "ls --color=tty";
171 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
174 st="sudo systemctl status";
175 u="systemctl --user";
176 j="sudo journalctl -u";
177 jb="sudo journalctl -b";
179 nix-history="sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
181 sshfs = "sshfs -o ServerAliveInterval=15 -o reconnect -f";
191 openFirewall = false;
201 fileSystems."/home/julm/mnt/ilico/severine" = {
202 device = "https://nuage.ilico.org/remote.php/dav/files/severine/";
205 let conf = pkgs.writeText "davfs2.conf" ''
206 backup_dir /home/julm/documents/backup/ilico/severine
207 cache_dir /home/julm/.cache/davfs2/ilico/severine
209 [ "conf=${conf}" "user" "noexec" "nosuid" "noauto" ]; # "x-systemd.automount"
212 packages = [ pkgs.gnome3.dconf ];
219 defaultMode = "online";
222 localDiscovery = false;
224 Datastore.StorageMax = "10GB";
225 Discovery.MDNS.Enabled = false;
228 #Swarm.AddrFilters = null;
230 startWhenNeeded = true;
232 services.journald = {
235 MaxRetentionSec=1month
240 services.printing = {
249 # Allow members of the "adbusers" group to mount Android devices via MTP.
250 pkgs.android-udev-rules
251 # Allow the console user access the Yubikey USB device node,
252 # needed for challenge/response to work correctly.
253 pkgs.yubikey-personalization
259 xkbOptions = "eurosign:e";
260 libinput.enable = true;
263 # Let the session be generated by home-manager
264 { name = "home-manager";
266 ${pkgs.runtimeShell} $HOME/.hm-xsession &
273 defaultSession = "home-manager";
274 #defaultSession = "none+xmonad";
277 user = users.julm.name;
282 systemd.coredump.enable = true;
283 #environment.enableDebugInfo = true;
285 # This value determines the NixOS release with which your system is to be
286 # compatible, in order to avoid breaking some software such as database
287 # servers. You should change this only after NixOS release notes say you should.
288 system.stateVersion = "20.09"; # Did you read the comment?