4 interactiveShellInit = ''
5 bind '"\e[A":history-search-backward'
6 bind '"\e[B":history-search-forward'
8 # Ignore duplicate commands, ignore commands starting with a space
9 export HISTCONTROL=erasedups:ignorespace
11 # Append to the history instead of overwriting (good for multiple connections)
15 mkcd () { mkdir -p "$1"; cd "$1"; }
18 then sudo tee /proc/acpi/ibm/fan <<<"level $1"
19 else grep '^\(level\|speed\):' /proc/acpi/ibm/fan
26 grep = "grep --color";
29 ls = "ls --color=tty";
30 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
33 st="sudo systemctl status";
35 j="sudo journalctl -u";
36 jb="sudo journalctl -b";
38 nix-history="sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
40 sshfs = "sshfs -o ServerAliveInterval=15 -o reconnect -f";