5 enable = mkDefault true;
6 enableCompletion = mkDefault true;
8 afk = "xset s activate dpms force off";
9 black-on-white = "echo -e '\\033]11;black\\007\\033]10;white\\007'";
12 emacs = "emacsclient --create-frame";
13 grep = "grep --color";
14 j = "sudo journalctl -u";
15 jb = "sudo journalctl -b";
16 ju = "sudo journalctl --user -u";
19 ls = "ls --color=tty";
20 md-toc = "grep '^#\\+' --color";
21 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
22 mem-top = "smem --sort rss --autosize";
24 n = "sudo networkctl";
25 nf = "sudo nft list ruleset | less";
26 nix-du-svg = "nix-du | dot -Tsvg >nix-du.svg";
27 nixos-clean = "sudo nix-collect-garbage -d";
28 nixos-history = "sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
29 nixos-rollback = "sudo nixos-rebuild switch --rollback";
30 nt = "sudo networkctl status";
31 pass-gen = "tr -d -C A-Za-z0-9_- </dev/urandom | head -c";
33 rot13 = "tr A-Za-z N-ZA-Mn-za-m";
34 rot135 = "tr A-Za-z0-9 N-ZA-Mn-za-m5-90-4";
35 rsync = "rsync --no-inc-recursive --info=progress2 --inplace --partial";
37 sr = "sudo systemctl restart";
38 ssh-unknown = "ssh -o StrictHostKeyChecking=no -o UserKnownHostsFile=/dev/null";
39 st = "sudo systemctl status";
44 theme-black-on-white = "echo -e '\\033]10;black\\007\\033]11;white\\007'";
45 theme-white-on-black = "echo -e '\\033]10;white\\007\\033]11;black\\007'";
46 u = "systemctl --user";
47 ur = "systemctl --user restart";
48 ut = "systemctl --user status";
49 w = "watch --color --differences";
50 w1 = "watch --color --differences --interval 1";
51 w10 = "watch --color --differences --interval 10";
52 w5 = "watch --color --differences --interval 5";
53 watch = "watch --color --differences";
55 ze = "sudo zpool export";
56 zfs-umount = "zfs-unmount";
57 zi = "sudo zpool import";
59 zlb = "zfs list -t bookmarks";
60 zls = "zfs list -t snap";
64 zs5 = "w5 zpool status";
67 historyControl = [ "erasedups" "ignorespace" ];
74 PS1 = ''\[\033[1;32m\]\[\e]0;\u@\h: \w\a\]\W\[\033[0m\] \$(e=\$?; if [ \$e != 0 ]; then echo '\[\e[0;91m\]'\$e'\[\e[0m\]'; fi)\$ '';
75 # More throughput than chacha20-poly1305@openssh.com
76 # on hardware with AES acceleration.
77 RSYNC_RSH = "ssh -c aes128-gcm@openssh.com,chacha20-poly1305@openssh.com";
81 . ${pkgs.complete-alias}/bin/complete_alias
82 complete -F _complete_alias "''${!BASH_ALIASES[@]}"
88 # Disable ctrl-s/ctrl-q flow control
93 ffmpeg -i "$i" -vn -map 0:a -acodec copy "''${i%.*}".audio-only.mkv
98 ffmpeg -i "$i" -vn -map 0:a -c:a libopus -b:a 64k -application voip "''${i%.*}".opus
102 find "$@" -depth -type f -print0 | sort -n -z |
103 xargs -0 -P "$(lscpu --online -p | grep -v "#" | wc -l)" -I {} bash -c '
104 test -e "''${0%.*}".opus ||
105 nice -n 19 ffmpeg -y -i "$0" -map 0:a -b:a 32k -application voip "''${0%.*}".opus
110 then sudo tee /proc/acpi/ibm/fan <<<"level $1"
111 else grep '^\(level\|speed\):' /proc/acpi/ibm/fan
120 tr -d -C 'A-Za-z0-9' </dev/urandom | head -c 25 | xclip
123 device=''${1:-/dev/sda}
124 sudo smartctl -A $device |
126 $0 ~ /Power_On_Hours/ {
128 printf "%s / %d hours / %d days / %.2f years\n", $2, $10, $10 / 24, $10 / 24 / 365.25
130 $0 ~ /Total_LBAs_Written/ {
136 printf "%s / %s / %d mb / %.1f gb / %.3f tb\n", $2, $10, mb, gb, tb
137 printf "mean writes per hour / %.2f", mb/poh
139 $0 ~ /Airflow_Temperature_Cel/ { print $2 " / " $10}
140 $0 ~ /Wear_Leveling_Count/ { printf "%s / %d (%% health)\n", $2, int($4) }
141 $0 ~ /Percentage Used:/ { printf "Percentage_Used / %d\n", int($3) }
144 sed -e "s\$^\$$device @ \$" |
147 stress-mem() { fac="$1"; stress-ng --vm 1 --vm-keep --vm-bytes $(awk "/MemAvailable/{ printf \"%d\n\", \$2 * $fac; }" </proc/meminfo)k; }
148 sysenter() { srv="$1"; shift; nsenter -a -t "$(systemctl show --property MainPID --value "$srv")" "$@"; }
149 systrace() { srv="$1"; shift; strace -f -p "$(systemctl show --property MainPID --value "$srv")" "$@"; }
153 sudo grep -H '^Swap:' /proc/*/smaps 2>/dev/null |
154 while IFS=: read -r file x size x
160 if test "$pid" = "$lastpid"
161 then swap=$(( swap + size ))
163 if test "$swap" -gt 0
164 then printf "%u pid=%u cmd=%s\n" "$swap" "$lastpid" "$(tr '\000' ' ' </proc/"$lastpid"/cmdline)"
166 if test "$pid" = self
177 # Recursively mount not-mounted dataset,
178 # loading their keys if needed.
182 for d in $(zfs list -rH -o name "$@"); do
183 mountpoint /mnt/"$d" 2>/dev/null ||
184 sudo zfs mount -l "$d"
188 # Recursively unmount dataset,
189 # unloading their keys.
190 zfs-unmount () { sudo zfs unmount -u "$@"; }
192 # Create bookmarks for all the snapshots of the given datasets.
193 # Bookmarks are only useful on source datasets
194 # But syncoid --create-bookmark only creates
195 # a bookmark for the latest snapshot,
196 # possibly leaving the *_daily or *_monthly snapshots without a bookmark.
197 zfs-fix-bookmarks () {
202 for s in $(zfs list -Hrpt snapshot -o name "$d"); do
203 zfs bookmark "$s" "''${s//@/#}"
208 # Restore the inheritance of encryptionroot,
209 # usually broken by zfs send --raw.
210 # Note that it needs to decrypt the datasets.
211 zfs-fix-encryptionroot () {
214 for d in $(zfs list -rHo name "$1" | tail -n +2); do
216 test "$(zfs get -Ho value encryptionroot $d)" = "$1" ||
217 zfs change-key -li "$d"
221 # Recursively remove all the snapshots of given datasets
222 zfs-destroy-snapshots () {
225 zfs list -t snapshot -rHo name "$d" |
226 xargs --no-run-if-empty -L1 zfs destroy
233 #programs.broot.enableBashIntegration = true;
234 programs.readline = {
235 enable = mkDefault true;
236 includeSystemConfig = true;
239 "\\e[A" = "history-search-backward";
240 "\\e[B" = "history-search-forward";
241 "\\eOA" = "history-search-backward";
242 "\\eOB" = "history-search-forward";
244 # Ctrl-Left/Ctrl-Right
245 "\\e[1;5C" = "forward-word";
246 "\\e[1;5D" = "backward-word";
247 "\\e[5C" = "forward-word";
248 "\\e[5D" = "backward-word";
249 "\\e\\e[C" = "forward-word";
250 "\\e\\e[D" = "backward-word";
253 "\\e[1~" = "beginning-of-line";
254 "\\e[4~" = "end-of-line";
257 "\\e[3~" = "delete-char";
258 "\\e[2~" = "quoted-insert";
260 # For non RH/Debian xterm, can't hurt for RH/Debian xterm
261 "\\eOF" = "end-of-line";
262 "\\eOH" = "beginning-of-line";
264 # For freebsd console
265 "\\e[F" = "end-of-line";
266 "\\e[H" = "beginning-of-line";
269 "\\e[7~" = "beginning-of-line";
270 "\\e[8~" = "end-of-line";
271 "\\eOc" = "forward-word";
272 "\\eOd" = "backward-word";
277 input-meta = mkDefault true;
278 output-meta = mkDefault true;
279 colored-completion-prefix = mkDefault true;
280 colored-stats = mkDefault true; # Note that this may cause completion text blink in some terminals (e.g. xterm).
281 echo-control-characters = mkDefault true;
282 mark-symlinked-directories = mkDefault true;
283 menu-complete-display-prefix = mkDefault true;
284 show-all-if-ambiguous = mkDefault true;
285 show-all-if-unmodified = mkDefault true;
286 visible-stats = mkDefault false; # Append char to indicate type
287 enable-bracketed-paste = mkDefault true;