1 { config, pkgs, lib, inputs, hostName, ... }:
4 #../nixos/profiles/debug.nix
5 ../nixos/profiles/lang-fr.nix
6 ../nixos/profiles/security.nix
7 ../nixos/profiles/system.nix
8 #../nixos/profiles/tor.nix
10 aubergine/networking.nix
13 # Lower kernel's security for better performances
14 boot.kernelParams = [ "mitigations=off" ];
16 environment.etc.machine-id.source = aubergine/machine-id;
18 home-manager.users.julm = {
19 imports = [ ../homes/julm.nix ];
21 systemd.services.home-manager-julm.postStart = ''
22 ${pkgs.nix}/bin/nix-env --delete-generations +1 --profile /nix/var/nix/profiles/per-user/julm/home-manager
27 # Put the hashedPassword in /nix/store, but it will also be in /etc/passwd
28 # which is already world readable.
29 # printf %s $(mkpasswd -m md5crypt)
30 hashedPassword = lib.readFile aubergine/users/julm/login/hashedPassword;
38 # If created, zfs-mount.service would require:
39 # zfs set overlay=yes ${hostName}/home
41 openssh.authorizedKeys.keys = map lib.readFile [
42 ../users/root/ssh/losurdo.pub
43 ../users/julm/ssh/losurdo.pub
44 ../users/julm/ssh/oignon.pub
45 ../users/julm/ssh/redmi.pub
50 openssh.authorizedKeys.keys =
51 config.users.users.julm.openssh.authorizedKeys.keys;
54 #systemd.services.nix-daemon.serviceConfig.LoadCredentialEncrypted =
55 # "secret-key-files:" + aubergine/nix/secret-key-files;
58 #secret-key-files = /run/credentials/nix-daemon.service/secret-key-files.pem
61 trusted-users = [ config.users.users."julm".name ];
63 #"http://nix-localcache.losurdo.wg"
64 #"ssh://nix-ssh@losurdo.wg?priority=30"
65 #"ssh://nix-ssh@oignon.wg?priority=30"
67 trusted-public-keys = map lib.readFile [
68 ../users/root/nix/oignon.pub
71 nixPath = lib.mkForce [ "nixpkgs=${inputs.nixpkgs}" ];
73 #environment.etc."nixpkgs".source = pkgs.path;
74 #environment.etc."nixpkgs-overlays".source = inputs.self + "/nixpkgs";
76 nix.settings.allowed-users = [ config.users.users."nix-ssh".name ];
79 keys = map lib.readFile [
80 ../users/julm/ssh/losurdo.pub
81 ../users/sevy/ssh/patate.pub
82 ../users/julm/ssh/oignon.pub
86 environment.systemPackages = [
89 boot.extraModulePackages = [
90 #config.boot.kernelPackages.v4l2loopback
93 # This value determines the NixOS release with which your system is to be
94 # compatible, in order to avoid breaking some software such as database
95 # servers. You should change this only after NixOS release notes say you should.
96 system.stateVersion = "22.11"; # Did you read the comment?