sourcephile
/
git
/
julm
/
julm-nix.git
/ blob
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
|
commitdiff
|
tree
history
|
raw
|
HEAD
nixos-fallback: add service
[julm/julm-nix.git]
/
hosts
/
aubergine
/
backup.nix
1
{ pkgs, lib, config, hostName, ... }:
2
with builtins;
3
{
4
services.sanoid = {
5
enable = true;
6
extraArgs = [ "--verbose" ];
7
datasets = {
8
"${hostName}/home" = {
9
autosnap = true;
10
autoprune = true;
11
hourly = 12;
12
daily = 3;
13
monthly = 0;
14
yearly = 0;
15
recursive = true;
16
};
17
"${hostName}/var" = {
18
autosnap = true;
19
autoprune = true;
20
hourly = 12;
21
daily = 1;
22
monthly = 0;
23
yearly = 0;
24
recursive = true;
25
};
26
};
27
};
28
}