1 { config, pkgs, lib, inputs, private, hostName, ... }:
3 inherit (config.users) users;
4 inherit (config.services) davfs2;
8 ../profiles/dnscrypt-proxy2.nix
9 ../profiles/security.nix
17 home-manager.users.julm = {
20 inputs.nix-doom-emacs.hmModule
22 host.hardware = ["ThinkPad" "X201"];
24 systemd.services.home-manager-julm.postStart = ''
25 ${pkgs.nix}/bin/nix-env --delete-generations +1 --profile /nix/var/nix/profiles/per-user/julm/home-manager
27 security.lockKernelModules = false;
28 users.mutableUsers = false;
32 # Put the hashedPassword in /nix/store, but it will also be in /etc/passwd
33 # which is already world readable.
34 hashedPassword = lib.readFile ../private/world/julm/hashedPassword;
47 # If created, zfs-mount.service would require:
48 # zfs set overlay=yes ${hostName}/home
54 secret-key-files = ${private}/${hostName}/nix/binary-cache/priv.pem
56 autoOptimiseStore = true;
60 options = "--delete-older-than 7d";
63 "nixpkgs=/etc/nixpkgs"
64 "nixpkgs-overlays=/etc/nixpkgs-overlays/overlays.nix"
66 trustedUsers = [ users.julm.name ];
67 binaryCaches = [ "https://nix-localcache.sourcephile.fr" ];
68 binaryCachePublicKeys = [ "losurdo.sourcephile.fr-1:XGeaIE2AA2mZskSZ5bIDrfx53q+TDDWJOUEpZDX7los=" ];
80 keys = [ (lib.readFile ../private/world/julm/losurdo/ssh.pub) ];
82 users.users.julm.openssh.authorizedKeys.keys = [
83 (lib.readFile ../private/world/julm/losurdo/ssh.pub)
85 services.openssh.openFirewall = false;
86 services.openssh.forwardX11 = true;
87 services.openssh.passwordAuthentication = false;
89 nixpkgs.config.allowUnfree = true;
90 environment.etc."nixpkgs".source = pkgs.path;
91 environment.etc."nixpkgs-overlays".source = inputs.self + "/nixpkgs";
93 time.timeZone = "Europe/Paris";
94 i18n.defaultLocale = "fr_FR.UTF-8";
95 console.font = "Lat2-Terminus16";
96 console.keyMap = "fr";
100 domain = "localdomain";
101 search = [ "sourcephile.fr" ];
108 #backend = "wpa_supplicant";
119 hardware.pulseaudio.enable = true;
120 hardware.sane.enable = true;
121 hardware.sane.extraBackends = [ pkgs.hplipWithPlugin ];
123 environment.variables = {
126 SYSTEMD_LESS = "FKMRX";
128 environment.systemPackages = [
135 interactiveShellInit = ''
136 bind '"\e[A":history-search-backward'
137 bind '"\e[B":history-search-forward'
139 # Ignore duplicate commands, ignore commands starting with a space
140 export HISTCONTROL=erasedups:ignorespace
141 export HISTSIZE=42000
142 # Append to the history instead of overwriting (good for multiple connections)
146 mkcd () { mkdir -p "$1"; cd "$1"; }
149 then sudo tee /proc/acpi/ibm/fan <<<"level $1"
150 else grep '^\(level\|speed\):' /proc/acpi/ibm/fan
157 grep = "grep --color";
160 ls = "ls --color=tty";
161 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
164 st="sudo systemctl status";
165 u="systemctl --user";
166 j="sudo journalctl -u";
167 jb="sudo journalctl -b";
169 nix-history="sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
171 sshfs = "sshfs -o ServerAliveInterval=15 -o reconnect -f";
181 openFirewall = false;
191 fileSystems."/home/julm/mnt/ilico/severine" = {
192 device = "https://nuage.ilico.org/remote.php/dav/files/severine/";
195 let conf = pkgs.writeText "davfs2.conf" ''
196 backup_dir /home/julm/documents/backup/ilico/severine
197 cache_dir /home/julm/.cache/davfs2/ilico/severine
199 [ "conf=${conf}" "user" "noexec" "nosuid" "noauto" ]; # "x-systemd.automount"
202 packages = [ pkgs.gnome3.dconf ];
209 defaultMode = "online";
212 localDiscovery = false;
214 Datastore.StorageMax = "10GB";
215 Discovery.MDNS.Enabled = false;
218 #Swarm.AddrFilters = null;
220 startWhenNeeded = true;
222 services.journald = {
225 MaxRetentionSec=1month
230 services.printing = {
239 # Allow members of the "adbusers" group to mount Android devices via MTP.
240 pkgs.android-udev-rules
241 # Allow the console user access the Yubikey USB device node,
242 # needed for challenge/response to work correctly.
243 pkgs.yubikey-personalization
249 xkbOptions = "eurosign:e";
250 libinput.enable = true;
253 # Let the session be generated by home-manager
254 { name = "home-manager";
256 ${pkgs.runtimeShell} $HOME/.hm-xsession &
263 defaultSession = "home-manager";
264 #defaultSession = "none+xmonad";
267 user = users.julm.name;
272 systemd.coredump.enable = true;
273 #environment.enableDebugInfo = true;
275 # This value determines the NixOS release with which your system is to be
276 # compatible, in order to avoid breaking some software such as database
277 # servers. You should change this only after NixOS release notes say you should.
278 system.stateVersion = "20.09"; # Did you read the comment?