1 { config, lib, pkgs, hostName, ... }:
4 ../../nixos/profiles/hardware/X200.nix
5 ../../nixos/profiles/zfs.nix
6 ../../nixos/profiles/zramSwap.nix
12 device = "/dev/disk/by-id/ata-CT250MX500SSD1_2004E2849DD1";
13 configurationLimit = 3;
17 { device = "/dev/disk/by-partlabel/${hostName}_ssd_boot";
20 fileSystems."/boot/efi" =
21 { device = "/dev/disk/by-partlabel/${hostName}_ssd_efi";
25 { device = "/dev/disk/by-partlabel/${hostName}_ssd_swap";
28 cipher = "aes-xts-plain64";
29 source = "/dev/urandom";
34 # The 32-bit host id of the host, formatted as 8 hexadecimal characters.
35 # You should try to make this id unique among your hosts.
36 # Manually generated with : head -c4 /dev/urandom | od -A none -t x4 | cut -d ' ' -f 2
37 networking.hostId = "ec2adb40";
39 boot.supportedFilesystems = [ "ntfs" "vfat" ];
40 boot.extraModulePackages = [
41 #config.boot.kernelPackages.exfat-nofuse
44 powerManagement.powertop.enable = true;
47 { device = "${hostName}/root";
51 { device = "${hostName}/nix";
54 fileSystems."/home/sevy" =
55 { device = "${hostName}/home";
58 fileSystems."/home/sevy/Documents" =
59 { device = "${hostName}/home/Documents";
62 fileSystems."/home/sevy/Images" =
63 { device = "${hostName}/home/Images";
66 fileSystems."/home/sevy/Téléchargements" =
67 { device = "${hostName}/home/Downloads";
70 fileSystems."/home/sevy/.thunderbird" =
71 { device = "${hostName}/home/Mails";
74 fileSystems."/home/sevy/Vidéos" =
75 { device = "${hostName}/home/Videos";
79 { device = "${hostName}/var";
82 fileSystems."/var/cache" =
83 { device = "${hostName}/var/cache";
86 fileSystems."/var/log" =
87 { device = "${hostName}/var/log";
90 fileSystems."/var/tmp" =
91 { device = "${hostName}/var/tmp";