{ pkgs, lib, hostName, ... }:
with builtins;
{
  services.sanoid = {
    enable = true;
    extraArgs = [ "--verbose" ];
    datasets = {
      "${hostName}/root/home/mo" = {
        autosnap = true;
        autoprune = true;
        hourly = 0;
        daily = 15;
        monthly = 0;
        yearly = 0;
        recursive = true;
      };
      "${hostName}/root/home/mo/.cache" = {
        autosnap = false;
      };
      "${hostName}/root/home/mo/.mozilla" = {
        autosnap = true;
        autoprune = true;
        daily = 3;
      };
      "${hostName}/root/home/mo/.thunderbird" = {
        autosnap = true;
        autoprune = true;
        hourly = 12;
        daily = 7;
      };
      "${hostName}/root/home/mo/Documents" = {
        autosnap = true;
        autoprune = true;
        hourly = 12;
        daily = 31;
      };
      "${hostName}/root/home/mo/Telechargements" = {
        autosnap = false;
      };
    };
  };
}