# Usage:
# nix -L build .#nixosConfigurations.minimal.config.system.build.isoImage
# sudo dd if=result/iso/nixos-24.11-patch-75f694f-x86_64-linux.iso of=/dev/disk/by-id/usb-Generic_Mass-Storage-0\:0 status=progress bs=4M
# sync
{
  pkgs,
  lib,
  config,
  inputs,
  hosts,
  modulesPath,
  ...
}:
{
  imports = [
    (modulesPath + "/installer/cd-dvd/installation-cd-minimal.nix")
  ];

  # Lower kernel's security for better performances
  security.kernel.mitigations = "off";

  nixpkgs.hostPlatform = {
    system = "x86_64-linux";
    config = "x86_64-unknown-linux-gnu";
  };

  ## Some useful options for setting up a new system
  services.getty.autologinUser = lib.mkForce "root";
  users.users.root.openssh.authorizedKeys.keys =
    hosts.blackberry.config.users.users.julm.openssh.authorizedKeys.keys;
  #console.keyMap = "de";
  # hardware.video.hidpi.enable = true;

  # Faster
  isoImage.squashfsCompression = lib.mkDefault "gzip -Xcompression-level 1";

  system.stateVersion = config.system.nixos.release;

  documentation = {
    enable = false;
    doc.enable = false;
  };

}