{
  imports = [
    ./ssh.nix
  ];
  # On a remote headless server: always reboot on a kernel panic,
  # to not have to physically go power cycle the server.
  # Which may happen for instance if the wrong ZFS password is used
  # but the boot is manually forced to continue.
  # Using kernelParams instead of kernel.sysctl
  # sets this up as soon as the initrd.
  boot.kernelParams = [ "panic=10" ];

  programs.gnupg.agent.pinentryFlavor = "curses";

  # Always try to start all the units (default.target)
  # because systemd's emergency shell does not try to start sshd.
  # https://wiki.archlinux.org/index.php/systemd#Disable_emergency_mode_on_remote_host
  systemd.enableEmergencyMode = false;
}