{ inputs, ... }:
{
  nix.extraOptions = ''
    experimental-features = nix-command flakes
  '';
  #nix.registry.self.flake = inputs.self;
  # Pin the rev to the revision of the public Nixpkgs that the system was built from.
  # This is the version which will be locked by flakes using flake:nixpkgs
  nix.registry.nixpkgs = {
    from = { id = "nixpkgs"; type = "indirect"; };
    to = {
      owner = "NixOS";
      repo = "nixpkgs";
      inherit (inputs.nixpkgs) rev;
      type = "github";
    };
  };
  nix.nixPath = [
    "nixpkgs=${inputs.nixpkgs}"
  ];
}