{ pkgs, lib, config, hostName, private, ... }:
{
networking.wireguard.wg-intra.peers.mermet.enable = true;
networking.wireguard.wg-intra.peers.losurdo.enable = true;
networking.hosts."192.168.42.2" = [
  "sourcephile.wg"
  "builds.sourcephile.wg"
  "dispatch.sourcephile.wg"
  "git.sourcephile.wg"
  "hg.sourcephile.wg"
  "hub.sourcephile.wg"
  "lists.sourcephile.wg"
  "man.sourcephile.wg"
  "meta.sourcephile.wg"
  "pages.sourcephile.wg"
  "paste.sourcephile.wg"
  "todo.sourcephile.wg"
];
/*
systemd.services =
  {
    openssh = {
      after = ["wireguard-${iface}.service"];
      serviceConfig.Restart = "on-failure";
    };
  };
services.openssh.listenAddresses = map (ip: {addr=lib.removeSuffix "/32" ip;}) peer.allowedIPs;
*/
}