fcitx5: tweak classicui settings
[julm/julm-nix.git] / nixos / profiles / networking / ssh.nix
index eb1322b6f25ab014877695dba223f43a574571cc..d3fee5925877fcd673891e4e9655be17e89a3b2d 100644 (file)
@@ -1,10 +1,13 @@
-{ lib, inputs, hostName, ... }:
+{
+  lib,
+  inputs,
+  hostName,
+  ...
+}:
 with lib;
 {
   programs.mosh.enable = mkDefault true;
   services.openssh.enable = true;
-  systemd.services.sshd.serviceConfig.LoadCredentialEncrypted =
-    [ "host.key:${inputs.self}/hosts/${hostName}/ssh/host.key.cred" ];
   # TODO: use hostKeys= once LoadCredentialEncrypted= works in ExecStartPre=
   services.openssh.hostKeys = mkForce [ ];
   services.openssh.extraConfig = ''