aubergine: try other linux version
[julm/julm-nix.git] / home-manager / profiles / git.nix
index 842cc65076f6f92288f078ae92de0625b63b5af5..b284e5ff4487bef62f4e79403e577a5605179356 100644 (file)
       wip = "for-each-ref --sort='authordate:iso8601' --format=' %(color:green)%(authordate:relative)%09%(color:white)%(refname:short)' refs/heads";
     };
     extraConfig = {
-      push.default = "simple";
+      browser.elinks.cmd = "elinks";
+      color.branch = "auto";
       color.diff = "auto";
       #color.diff.whitespace = "red reverse";
       color.status = "auto";
-      color.branch = "auto";
-      core.whitespace = "fix,-indent-with-non-tab,trailing-space,cr-at-eol";
+      core.commentChar = "auto";
       core.quotepath = "false";
+      core.whitespace = "fix,-indent-with-non-tab,trailing-space,cr-at-eol";
       diff.algorithm = "histogram";
       diff.sqldiff.command = "sqldiff";
       format.pretty = "oneline";
       init.defaultBranch = "main";
-      web.browser = "elinks";
-      browser.elinks.cmd = "elinks";
+      merge.tool = "vimdiff";
+      protocol.version = 2;
+      pull.rebase = true;
+      push.default = "simple";
+      rebase.autosquash = "true";
       sendemail.chainReplyTo = "false";
       sendemail.composeencoding = "UTF-8";
       sendemail.confirm = "always";
       sendemail.envelopeSender = "auto";
       sendemail.multiedit = "yes";
-      sendemail.suppresscc = "self";
       sendemail.suppressFrom = "false";
+      sendemail.suppresscc = "self";
       sendemail.thread = "true";
       sendemail.validate = "true";
-      merge.tool = "vimdiff";
-      protocol.version = 2;
-      pull.rebase = true;
-      rebase.autosquash = "true";
+      web.browser = "elinks";
     };
   };
 }