programs.git.package = pkgs.gitMinimal;
programs.gpg.enable = true;
programs.htop.enable = true;
+programs.home-manager.enable = true;
programs.ssh.enable = true;
programs.vim.enable = true;
home.file.".profile".text = ''
# Tell XFCE to not start ssh-agent
- ! command -v xfconf-query >/dev/null ||
- xfconf-query -c xfce4-session -p /startup/ssh-agent/enabled -n -t bool -s false
+ if command -v xfconf-query >/dev/null && test ''${DISPLAY:+set}; then
+ xfconf-query -c xfce4-session -p /startup/ssh-agent/enabled -n -t bool -s false
+ fi
'';
services.gpg-agent.enable = true;
services.redshift.enable = config.host.desktop;
+home.sessionPath = [ "${config.home.homeDirectory}/bin" ];
home.sessionVariables = {
EDITOR = "vim -g";
LANG = "fr_FR.UTF-8";
LESS = "-FRSX";
LOCALE_ARCHIVE = "${pkgs.glibcLocales}/lib/locale/locale-archive";
MANPAGER = "less";
- PATH = lib.makeBinPath [ config.home.homeDirectory ] + ":$PATH";
};
home.packages = [
pkgs.acpi
pkgs.curl
pkgs.dino
#pkgs.dnsutils
+ pkgs.dstat
pkgs.ffmpeg
pkgs.file
pkgs.git-crypt
+ pkgs.go-mtpfs
pkgs.gnumake
pkgs.gvfs
#pkgs.haskell.packages.ghc865.zerobin
pkgs.xdg_utils
pkgs.youtube-dl
] ++ lib.optionals config.host.desktop [
- pkgs.amule
+ #pkgs.amule
pkgs.chromium
pkgs.djview
pkgs.dmenu
pkgs.evince
pkgs.firefox
+ pkgs.freecad
pkgs.freeciv_gtk
pkgs.geeqie
pkgs.gimp
pkgs.gparted
+ pkgs.graphviz
pkgs.keepass
pkgs.libdvdcss
pkgs.libreoffice