aubergine: nftables: fix DHCP renewal
[julm/julm-nix.git] / nixos / profiles / tlp.nix
index 2cc4761345a6bdd6f3089ee9e1b6159e493dd5bf..02e7c603f41a884acffcbbc721c2416e466e9d35 100644 (file)
@@ -1,4 +1,4 @@
-{ lib, ... }:
+{ lib, config, ... }:
 with lib;
 {
   # Preloading the kernel modules to avoid:
@@ -8,7 +8,8 @@ with lib;
     "cpufreq_powersave"
   ];
   services.tlp = {
-    enable = true;
+    # Gnome 40 introduced a new way of managing power, without tlp.
+    enable = mkDefault (!config.services.power-profiles-daemon.enable);
     settings = {
       CPU_SCALING_GOVERNOR_ON_AC = "ondemand";
       CPU_SCALING_GOVERNOR_ON_BAT = "powersave";