veloren: update and fix
[julm/julm-nix.git] / home-manager / profiles / gnupg.nix
index 85b7d938320c99dc1ba6c37c651b2feb3eed3efa..b25e60a658862810245c97942df862edfff56ccb 100644 (file)
@@ -1,4 +1,10 @@
-{ pkgs, lib, config, nixosConfig, ... }:
+{
+  pkgs,
+  lib,
+  config,
+  nixosConfig,
+  ...
+}:
 {
   /*
     home.activation.gnupg = lib.hm.dag.entryAfter ["writeBoundary"] ''
@@ -9,7 +15,9 @@
     enable = true;
     enableSshSupport = true;
     enableExtraSocket = true;
-    pinentryFlavor = lib.mkDefault (if nixosConfig.services.xserver.enable then "gtk2" else "curses");
+    pinentryPackage = lib.mkDefault (
+      if nixosConfig.services.xserver.enable then pkgs.pinentry-gtk2 else pkgs.pinentry-curses
+    );
   };
   programs.gpg.enable = true;
   programs.gpg.settings = {
     #standard-resolver
   '';
   home.packages = lib.mkIf config.programs.gpg.enable [
-    (pkgs.pass.withExtensions (ext: with ext; [
-      pass-audit
-      pass-checkup
-      pass-file
-      pass-genphrase
-      pass-import
-      pass-otp
-      pass-tomb
-      pass-update
-    ]))
+    (pkgs.pass.withExtensions (
+      ext: with ext; [
+        pass-audit
+        pass-checkup
+        #pass-file
+        pass-genphrase
+        pass-import
+        pass-otp
+        pass-tomb
+        pass-update
+      ]
+    ))
   ];
 }