aubergine: cups: do not enforce HTTPS
[julm/julm-nix.git] / hosts / aubergine / hardware.nix
index 0a695eebb64158932427edcff17a9bf9b1bac0c2..62da31c3c9405fb04d4088b27bcc9a7205becf7b 100644 (file)
@@ -1,10 +1,12 @@
-{ lib, hostName, ... }:
+{ pkgs, lib, hostName, ... }:
 {
   imports = [
     ../../nixos/profiles/hardware/apu6b4.nix
     ../../nixos/profiles/hardware/ME909u-521.nix
+    ../../nixos/profiles/serial.nix
     ../../nixos/profiles/zfs.nix
     ../../nixos/profiles/zramSwap.nix
+    ../../nixos/profiles/pipewire.nix
   ];
 
   # Setting the machine-id avoids to reencrypt all credentials
   */
   boot.loader.grub = {
     enable = true;
-    version = 2;
     devices = [
       #"/dev/disk/by-id/mmc-SU08G_0xb0320f0f"
-      "/dev/disk/by-id/usb-Generic-_Multi-Card_20071114173400000-0:0"
+      #"/dev/disk/by-id/usb-Generic-_Multi-Card_20071114173400000-0:0"
+      "/dev/disk/by-id/ata-YMTC_JGS_2201060101833"
     ];
     configurationLimit = 9;
 
     #efiSupport = true;
     #enableCryptodisk = true;
   };
-  boot.tmpOnTmpfs = true;
-
-  fileSystems."/" =
-    {
-      device = "/dev/disk/by-partlabel/${hostName}_sd_root";
-      fsType = "ext4";
-    };
-  fileSystems."/boot/efi" =
-    {
-      device = "/dev/disk/by-partlabel/${hostName}_sd_efi";
-      fsType = "vfat";
-    };
-  /*
-    swapDevices = [
-    { device = "/dev/disk/by-partlabel/${hostName}_ssd_swap";
-    randomEncryption = {
-      enable = true;
-      cipher = "aes-xts-plain64";
-      source = "/dev/urandom";
-    };
-    }
-    ];
-  */
 
   boot.supportedFilesystems = [ /*"ntfs"*/ "vfat" ];
   boot.extraModulePackages = [
     #config.boot.kernelPackages.exfat-nofuse
   ];
+  boot.zfs.requestEncryptionCredentials = [ hostName ];
+
+  hardware.enableRedistributableFirmware = true;
 
   powerManagement.powertop.enable = true;
+
   #services.fprintd.enable = true;
 
-  /*
-    fileSystems."/" =
-    { device = "${hostName}/root";
-    fsType = "zfs";
+  fileSystems."/" =
+    {
+      device = "${hostName}/root";
+      fsType = "zfs";
     };
-    fileSystems."/nix" =
-    { device = "${hostName}/nix";
-    fsType = "zfs";
+  fileSystems."/boot" =
+    {
+      device = "/dev/disk/by-partlabel/${hostName}_ssd_boot";
+      fsType = "ext4";
     };
-    fileSystems."/var" =
-    { device = "${hostName}/var";
-    fsType = "zfs";
+  fileSystems."/boot/efi" =
+    {
+      device = "/dev/disk/by-partlabel/${hostName}_ssd_efi";
+      fsType = "vfat";
     };
-  */
-
-  hardware.pulseaudio.enable = lib.mkDefault true;
-  #hardware.pulseaudio.tcp.enable = lib.mkDefault true;
+  fileSystems."/nix" =
+    {
+      device = "${hostName}/nix";
+      fsType = "zfs";
+    };
+  fileSystems."/var" =
+    {
+      device = "${hostName}/var";
+      fsType = "zfs";
+    };
+  fileSystems."/home" =
+    {
+      device = "${hostName}/home";
+      fsType = "zfs";
+    };
+  swapDevices =
+    [
+      {
+        device = "/dev/disk/by-partlabel/${hostName}_ssd_swap";
+        randomEncryption = {
+          enable = true;
+          cipher = "aes-xts-plain64";
+          source = "/dev/urandom";
+        };
+      }
+    ];
 
 }