programs.git = {
enable = true;
ignores = [ "*~" "*.swp" ];
- package = pkgs.gitFull;
+ package = lib.mkDefault pkgs.gitFull;
aliases = {
+ a = "add";
authors = "shortlog -s -n";
bl = "git log -p -M --follow --stat --";
b = "branch";
c = "commit";
ca = "commit --amend -C@";
+ cf = "commit --fixup";
co = "checkout";
d = "diff";
dc = "diff --cached";
dp = "diff --patience";
ign = "ls-files -o -i --exclude-standard";
ll = "log --graph --decorate --pretty=oneline --abbrev-commit";
- lp = "log -p";
+ lp = "log -p --pretty=fuller";
s = "status";
spull = "!git-svn fetch && git-svn rebase";
spush = "!git-svn dcommit";
ss = "status -s";
- su = "status -uno";
+ st = "status -uno";
sw = "switch";
fetch-local = "!git fetch local && git tag -d $(git describe --exact-match 2>/dev/null >/dev/null) && git fetch --tags local";
pull-local = "!git fetch-local && git checkout -B master local/master";