julm/mutt.nix
(import (julm/hosts + "/${hostName}.nix"))
];
+ programs.bash.shellAliases = {
+ firefox-calyx = "sudo systemd-run -P -p JoinsNamespaceOf=netns-calyx.service -p PrivateNetwork=true -p BindReadOnlyPaths=/etc/netns/calyx/resolv.conf:/etc/resolv.conf -E DISPLAY=$DISPLAY -p User=julm -E DBUS_SESSION_BUS_ADDRESS=$DBUS_SESSION_BUS_ADDRESS -E LANG=$LANG -E LOCALE_ARCHIVE=$LOCALE_ARCHIVE -E PATH=$PATH -- firefox -P calyx";
+ };
programs.firefox.profiles =
let
defaultProfile = {
id = 1;
name = "tor";
settings = {
- "browser.startup.homepage" = "https://check.torproject.org/";
+ "browser.startup.homepage" = "https://check.torproject.org";
+ "privacy.firstparty.isolate" = true;
+ };
+ }
+ ];
+ "zqa1ck7d.calyx" = lib.mkMerge [
+ defaultProfile
+ {
+ id = 2;
+ name = "calyx";
+ settings = {
+ "browser.startup.homepage" = "https://icanhazip.com";
"privacy.firstparty.isolate" = true;
};
}