essential: no longer set the `LOCALE_ARCHIVE` envvar
[julm/julm-nix.git] / homes / julm.nix
index 6af5382b9310235dc8c76b01a1b4368b60b033c5..1104fe845678ca8be5b79f49c746da96a3050d8a 100644 (file)
@@ -7,6 +7,9 @@
     julm/mutt.nix
     (import (julm/hosts + "/${hostName}.nix"))
   ];
+  programs.bash.shellAliases = {
+    firefox-calyx = "sudo systemd-run -P -p JoinsNamespaceOf=netns-calyx.service -p PrivateNetwork=true -p BindReadOnlyPaths=/etc/netns/calyx/resolv.conf:/etc/resolv.conf -E DISPLAY=$DISPLAY -p User=julm -E DBUS_SESSION_BUS_ADDRESS=$DBUS_SESSION_BUS_ADDRESS -E LANG=$LANG -E LOCALE_ARCHIVE=$LOCALE_ARCHIVE -E PATH=$PATH -- firefox -P calyx";
+  };
   programs.firefox.profiles =
     let
       defaultProfile = {
           id = 1;
           name = "tor";
           settings = {
-            "browser.startup.homepage" = "https://check.torproject.org/";
+            "browser.startup.homepage" = "https://check.torproject.org";
+            "privacy.firstparty.isolate" = true;
+          };
+        }
+      ];
+      "zqa1ck7d.calyx" = lib.mkMerge [
+        defaultProfile
+        {
+          id = 2;
+          name = "calyx";
+          settings = {
+            "browser.startup.homepage" = "https://icanhazip.com";
             "privacy.firstparty.isolate" = true;
           };
         }