{ config, pkgs, lib, inputs, hostName, ... }:
-let inherit (config.users) users; in
{
-imports = [
- ../profiles/dnscrypt-proxy2.nix
- oignon/hardware.nix
- oignon/tor.nix
-];
-
-home-manager.users.julm = {
- imports = [ ../homes/julm.nix ];
- host.name = hostName;
- host.hardware = ["ThinkPad" "X201"];
-};
-systemd.services.home-manager-julm.postStart = ''
- ${pkgs.nix}/bin/nix-env --delete-generations +1 --profile /nix/var/nix/profiles/per-user/julm/home-manager
-'';
-users.mutableUsers = false;
-users.users.julm = {
- isNormalUser = true;
- uid = 1000;
- # Put the hashedPassword in /nix/store, but it will also be in /etc/passwd
- # which is already world readable.
- hashedPassword = lib.readFile ../secrets/julm/hashedPassword;
- extraGroups = [
- "adbusers"
- "lp"
- "networkmanager"
- "scanner"
- "tor"
- "video"
- "wheel"
- "networkmanager"
- #"vboxusers"
+ imports = [
+ ../nixos/profiles/builder.nix
+ ../nixos/profiles/debug.nix
+ ../nixos/profiles/graphical.nix
+ ../nixos/profiles/lang-fr.nix
+ ../nixos/profiles/printing.nix
+ ../nixos/profiles/tor.nix
+ ../nixos/profiles/irssi.nix
+ oignon/backup.nix
+ oignon/hardware.nix
+ oignon/networking.nix
];
- # If created, zfs-mount.service would require:
- # zfs set overlay=yes ${hostName}/home
- createHome = false;
-};
-nix = {
- extraOptions = ''
- auto-optimise-store = true
+ # Lower kernel's security for better performances
+ boot.kernelParams = [ "mitigations=off" ];
+
+ home-manager.users.julm = {
+ imports = [ ../homes/julm.nix ];
+ };
+ systemd.services.home-manager-julm.postStart = ''
+ ${pkgs.nix}/bin/nix-env --delete-generations +1 --profile /nix/var/nix/profiles/per-user/julm/home-manager
'';
- gc = {
- automatic = true;
- dates = "weekly";
- options = "--delete-older-than 7d";
+ users.users.root = {
+ openssh.authorizedKeys.keys = map lib.readFile [
+ # For nix -L run .#oignon.switch
+ ../users/julm/ssh/oignon.pub
+ ];
+ };
+ users.users.julm = {
+ isNormalUser = true;
+ uid = 1000;
+ # Put the hashedPassword in /nix/store,
+ # though /etc/shadow is not world readable...
+ # printf %s $(mkpasswd -m md5crypt)
+ hashedPassword = lib.readFile oignon/users/julm/login/hashedPassword.clear;
+ extraGroups = [
+ "adbusers"
+ "dialout"
+ "lp"
+ "networkmanager"
+ "scanner"
+ "tor"
+ "video"
+ "wheel"
+ #"ipfs"
+ config.services.davfs2.davGroup
+ #"vboxusers"
+ ];
+ # If created, zfs-mount.service would require:
+ # zfs set overlay=yes ${hostName}/home
+ createHome = false;
+ openssh.authorizedKeys.keys = map lib.readFile [
+ ../users/julm/ssh/losurdo.pub
+ ];
};
- nixPath = [
- "nixpkgs=/etc/nixpkgs"
- "nixpkgs-overlays=/etc/nixpkgs-overlays/overlays.nix"
- ];
- trustedUsers = [ users.julm.name ];
-};
-environment.etc."nixpkgs".source = pkgs.path;
-environment.etc."nixpkgs-overlays".source = inputs.self + "/nixpkgs";
-
-nixpkgs.config = {
- allowUnfree = true;
-};
-documentation.nixos.enable = true;
-time.timeZone = "Europe/Paris";
-i18n.defaultLocale = "fr_FR.UTF-8";
-console.font = "Lat2-Terminus16";
-console.keyMap = "fr";
-networking = {
- hostName = hostName;
- domain = "localdomain";
- search = [ "sourcephile.fr" ];
- networkmanager = {
- enable = true;
- #dhcp = "dhcpcd";
- logLevel = "INFO";
- wifi = {
- #backend = "iwd";
- #backend = "wpa_supplicant";
- powersave = false;
+ systemd.services.nix-daemon.serviceConfig.LoadCredentialEncrypted =
+ [ ("${hostName}.key:${inputs.self}/hosts/${hostName}/nix/secret-key-files.priv.pem.cred") ];
+ nix = {
+ extraOptions = ''
+ secret-key-files = /run/credentials/nix-daemon.service/${hostName}.key
+ '';
+ settings = {
+ trusted-users = [ config.users.users."julm".name ];
+ substituters = [
+ #"http://nix-localcache.losurdo.wg"
+ "ssh://nix-ssh@losurdo.wg?priority=30"
+ ];
+ trusted-public-keys = map lib.readFile [
+ ../users/nix/ssh/losurdo.pub
+ ];
};
+ nixPath = lib.mkForce [ "nixpkgs=${inputs.nixpkgs}" ];
};
- firewall = {
+ #environment.etc."nixpkgs".source = pkgs.path;
+ #environment.etc."nixpkgs-overlays".source = inputs.self + "/nixpkgs";
+
+ nix.settings.allowed-users = [ config.users.users."nix-ssh".name ];
+ nix.sshServe = {
enable = true;
+ keys = map lib.readFile [
+ ../users/julm/ssh/losurdo.pub
+ ../users/julm/ssh/oignon.pub
+ ../users/sevy/ssh/patate.pub
+ ];
};
-};
-sound.enable = true;
-hardware.pulseaudio.enable = true;
-hardware.sane.enable = true;
-hardware.sane.extraBackends = [ pkgs.hplipWithPlugin ];
+ environment.systemPackages = [
+ pkgs.riseup-vpn # Can't be installed by home-manager because it needs to install policy-kit rules
+ ];
-environment.variables = {
- EDITOR = "vim";
- PAGER = "less -R";
- SYSTEMD_LESS = "FKMRX";
-};
+ boot.extraModulePackages = [
+ #config.boot.kernelPackages.v4l2loopback
+ ];
-programs = {
- bash = {
- interactiveShellInit = ''
- bind '"\e[A":history-search-backward'
- bind '"\e[B":history-search-forward'
+ programs.fuse.userAllowOther = true;
- # Ignore duplicate commands, ignore commands starting with a space
- export HISTCONTROL=erasedups:ignorespace
- export HISTSIZE=42000
- # Append to the history instead of overwriting (good for multiple connections)
- shopt -s histappend
+ services.davfs2.enable = true;
- # Utilities
- mkcd () { mkdir -p "$1"; cd "$1"; }
- fan () {
- if [ $# -gt 0 ]
- then sudo tee /proc/acpi/ibm/fan <<<"level $1"
- else grep '^\(level\|speed\):' /proc/acpi/ibm/fan
- fi
- acpi -t
- }
- '';
- shellAliases = {
- cl = "clear";
- grep = "grep --color";
- l = "ls -alh";
- ll = "ls -al";
- ls = "ls --color=tty";
- mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
+ fileSystems =
+ # Use the user's gpg-agent session to query
+ # for the password of the SSH key when auto-mounting.
+ let
+ sshAsUser = user:
+ pkgs.writeScript "sshAsUser-${user}" ''
+ exec ${pkgs.sudo}/bin/sudo -i -u ${user} \
+ ${pkgs.openssh}/bin/ssh "$@"
+ '';
+ options =
+ [
+ "user"
+ "uid=julm"
+ "gid=users"
+ "allow_other"
+ "exec" # Override "user"'s noexec
+ "noatime"
+ "nosuid"
+ "_netdev"
+ "ssh_command=${sshAsUser "julm"}" # "reconnect"
+ "noauto"
+ "x-gvfs-hide"
+ "x-systemd.automount"
+ #"Compression=yes" # YMMV
+ # Disconnect approximately 2*15=30 seconds after a network failure
+ "ServerAliveCountMax=1"
+ "ServerAliveInterval=15"
+ ];
+ in
+ {
+ "/mnt/aubergine" = {
+ device = "${pkgs.sshfs-fuse}/bin/sshfs#julm@aubergine.wg:/";
+ fsType = "fuse";
+ inherit options;
+ };
+ "/mnt/losurdo" = {
+ device = "${pkgs.sshfs-fuse}/bin/sshfs#julm@losurdo.wg:/";
+ fsType = "fuse";
+ inherit options;
+ };
+ "/mnt/mermet" = {
+ device = "${pkgs.sshfs-fuse}/bin/sshfs#julm@mermet.wg:/";
+ fsType = "fuse";
+ inherit options;
+ };
+ "/mnt/ilico/severine" = {
+ device = "https://nuage.ilico.org/remote.php/dav/files/severine/";
+ fsType = "davfs";
+ options =
+ let
+ conf = pkgs.writeText "davfs2.conf" ''
+ backup_dir /home/julm/.local/share/davfs2/ilico/severine
+ secrets /home/julm/.davfs2/secrets
+ '';
+ in
+ [
+ "conf=${conf}"
+ "user"
+ "noexec"
+ "nosuid"
+ "noauto"
+ "nofail"
+ "_netdev"
+ "reconnect"
+ "x-systemd.automount"
+ "x-systemd.device-timeout=1m"
+ "x-systemd.idle-timeout=1m"
+ "x-systemd.mount-timeout=10s"
+ ];
+ };
+ };
- s="sudo systemctl";
- st="sudo systemctl status";
- u="systemctl --user";
- j="sudo journalctl -u";
- jb="sudo journalctl -b";
+ networking.firewall.extraCommands = ''
+ ip46tables -A nixos-fw -i wg-intra -p tcp -m tcp --dport 8000 -j ACCEPT
+ '';
- nix-history="sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
- mv = "mv -i";
- sshfs = "sshfs -o ServerAliveInterval=15 -o reconnect -f";
+ services.kubo = {
+ #enable = true;
+ defaultMode = "online";
+ autoMount = true;
+ enableGC = true;
+ localDiscovery = false;
+ settings = {
+ Datastore.StorageMax = "10GB";
+ Discovery.MDNS.Enabled = false;
+ #Bootstrap = [
+ #];
+ #Swarm.AddrFilters = null;
};
+ startWhenNeeded = true;
};
- dconf.enable = true;
- mtr.enable = true;
-};
-services = {
- avahi = {
- enable = true;
- nssmdns = true;
- };
- dbus = {
- packages = [ pkgs.gnome3.dconf ];
- };
- gvfs = {
- enable = true;
- };
- journald = {
- extraConfig = ''
- Compress=true
- MaxRetentionSec=1month
- Storage=persistent
- SystemMaxUse=100M
- '';
- };
- printing = {
- enable = true;
- drivers = [
- pkgs.gutenprint
- pkgs.hplip
- ];
- };
- sanoid = {
- enable = true;
- extraArgs = [ "--verbose" ];
- datasets = {
- "${hostName}/home" = {
- autosnap = true;
- autoprune = true;
- hourly = 12;
- daily = 7;
- monthly = 0;
- yearly = 0;
- recursive = true;
- };
- "${hostName}/var" = {
- autosnap = true;
- autoprune = true;
- hourly = 12;
- daily = 7;
- monthly = 0;
- yearly = 0;
- recursive = true;
- };
- };
- };
- udev = {
- packages = [
- # Allow members of the "adbusers" group to mount Android devices via MTP
- pkgs.android-udev-rules
- ];
- };
- xserver = {
- enable = true;
- layout = "fr";
- xkbOptions = "eurosign:e";
- libinput.enable = true;
+ services.udev.packages = [
+ # Allow the console user access the Yubikey USB device node,
+ # needed for challenge/response to work correctly.
+ pkgs.yubikey-personalization
+ ];
+
+ services.xserver = {
+ layout = "fr,us(altgr-intl)";
desktopManager = {
session = [
# Let the session be generated by home-manager
- { name = "home-manager";
+ {
+ name = "home-manager";
start = ''
${pkgs.runtimeShell} $HOME/.hm-xsession &
waitPID=$!
displayManager = {
defaultSession = "home-manager";
#defaultSession = "none+xmonad";
+ #defaultSession = "mate";
+ #defaultSession = "cinnamon";
autoLogin = {
- enable = true;
- user = users.julm.name;
+ user = config.users.users.julm.name;
};
};
};
-};
-# This value determines the NixOS release with which your system is to be
-# compatible, in order to avoid breaking some software such as database
-# servers. You should change this only after NixOS release notes say you should.
-system.stateVersion = "20.09"; # Did you read the comment?
+ # This value determines the NixOS release with which your system is to be
+ # compatible, in order to avoid breaking some software such as database
+ # servers. You should change this only after NixOS release notes say you should.
+ system.stateVersion = "20.09"; # Did you read the comment?
}