-{ lib, config, hostName, ... }:
+{
+ lib,
+ config,
+ hostName,
+ ...
+}:
with (import ../networking/names-and-numbers.nix);
let
inherit (config.networking) domain;
#autoindex on;
return 444;
'';
- locations."/perso" = {
+ locations."/perso/photo" = {
+ #basicAuthFile = gnupg.secrets."nginx/perso/htpasswd".path;
+ extraConfig = ''
+ autoindex on;
+ #fancyindex on;
+ #fancyindex_exact_size off;
+ #fancyindex_name_length 255;
+ open_file_cache off;
+ #open_file_cache_valid 1s;
+ '';
+ };
+ locations."/perso/camera" = {
#basicAuthFile = gnupg.secrets."nginx/perso/htpasswd".path;
extraConfig = ''
autoindex on;
- fancyindex on;
- fancyindex_exact_size off;
- fancyindex_name_length 255;
+ #fancyindex on;
+ #fancyindex_exact_size off;
+ #fancyindex_name_length 255;
open_file_cache off;
#open_file_cache_valid 1s;
'';
"nginx/${domain}/${hostName}"
];
BindReadOnlyPaths = [
- "-/mnt/off2/julm/backup/das1/julm/perso:${root}/perso"
+ "-/mnt/off2/julm/backup/das1/julm/perso/photo:${root}/perso/photo"
+ "-/mnt/off2/julm/perso/camera:${root}/perso/camera"
];
};
};