bash: add zfs-fix-encryptionroot
[julm/julm-nix.git] / hosts / aubergine / nginx / aubergine.nix
index 386cf84ba8801b3d3c420587586f31f43785072f..35f7983f383f30de066f03d246a518ad573b099e 100644 (file)
@@ -26,7 +26,18 @@ in
         #autoindex on;
         return 444;
       '';
-      locations."/perso" = {
+      locations."/perso/photo" = {
+        #basicAuthFile = gnupg.secrets."nginx/perso/htpasswd".path;
+        extraConfig = ''
+          autoindex on;
+          fancyindex on;
+          fancyindex_exact_size off;
+          fancyindex_name_length 255;
+          open_file_cache off;
+          #open_file_cache_valid 1s;
+        '';
+      };
+      locations."/perso/camera" = {
         #basicAuthFile = gnupg.secrets."nginx/perso/htpasswd".path;
         extraConfig = ''
           autoindex on;
@@ -45,7 +56,8 @@ in
         "nginx/${domain}/${hostName}"
       ];
       BindReadOnlyPaths = [
-        "-/mnt/off2/julm/backup/das1/julm/perso:${root}/perso"
+        "-/mnt/off2/julm/backup/das1/julm/perso/photo:${root}/perso/photo"
+        "-/mnt/off2/julm/perso/camera:${root}/perso/camera"
       ];
     };
   };