-{ pkgs, lib, config, ... }:
+{ lib, ... }:
{
-programs.tmux = {
- enable = lib.mkDefault true;
- baseIndex = 1;
- clock24 = true;
- customPaneNavigationAndResize = true;
- extraConfig = builtins.readFile ./tmux.conf;
- historyLimit = 10000;
- keyMode = "vi";
- secureSocket = false; # So that it survives user's log-out
- sensibleOnTop = true;
- shortcut = "C-a";
- terminal = "screen-256color";
-};
+ programs.tmux = {
+ enable = lib.mkDefault true;
+ baseIndex = 1;
+ clock24 = true;
+ customPaneNavigationAndResize = true;
+ extraConfig = builtins.readFile ./tmux.conf;
+ historyLimit = 10000;
+ keyMode = "vi";
+ secureSocket = false; # So that it survives user's log-out
+ sensibleOnTop = true;
+ shortcut = "C-a";
+ terminal = "screen-256color";
+ };
}