mpv: add scripts/history.lua
[julm/julm-nix.git] / home-manager / profiles / tmux.nix
index 6d2639506f1a7ff22db10199a7653fc83198dc77..5fe7fcf13a56be2aa1185585f5cb6e4eb54d9fb9 100644 (file)
@@ -1,16 +1,16 @@
-{ pkgs, lib, config, ... }:
+{ lib, ... }:
 {
-programs.tmux = {
-  enable = lib.mkDefault true;
-  baseIndex = 1;
-  clock24 = true;
-  customPaneNavigationAndResize = true;
-  extraConfig = builtins.readFile ./tmux.conf;
-  historyLimit = 10000;
-  keyMode = "vi";
-  secureSocket = false; # So that it survives user's log-out
-  sensibleOnTop = true;
-  shortcut = "C-a";
-  terminal = "screen-256color";
-};
+  programs.tmux = {
+    enable = lib.mkDefault true;
+    baseIndex = 1;
+    clock24 = true;
+    customPaneNavigationAndResize = true;
+    extraConfig = builtins.readFile ./tmux.conf;
+    historyLimit = 10000;
+    keyMode = "vi";
+    secureSocket = false; # So that it survives user's log-out
+    sensibleOnTop = true;
+    shortcut = "C-a";
+    terminal = "screen-256color";
+  };
 }