oignon: iodine: install
[julm/julm-nix.git] / home-manager / profiles / bash.nix
index 6aaf62d44d5c4841b092090f14a99bb84253791f..19e3c8e5a147cebc4eef01a09eeaad20f733158b 100644 (file)
@@ -3,11 +3,14 @@
 programs.bash = {
   enable = lib.mkDefault true;
   shellAliases = {
+    black-on-white = "echo -e '\\033]11;black\\007\\033]10;white\\007'";
+    c = "bat";
     cl = "clear";
     eic = "edit-in-commit";
     eigg = "edit-in-git-grep";
     emacs = "emacsclient --create-frame";
     g = "git";
+    gg = "git grep";
     grep = "grep --color";
     j="sudo journalctl -u";
     jb="sudo journalctl -b";
@@ -25,13 +28,18 @@ programs.bash = {
     rsync = "rsync --no-inc-recursive --info=progress2 --inplace --partial";
     s="sudo systemctl";
     st="sudo systemctl status";
+    theme-black-on-white = "echo -e '\\033]10;black\\007\\033]11;white\\007'";
+    theme-white-on-black = "echo -e '\\033]10;white\\007\\033]11;black\\007'";
     u="systemctl --user";
     ut="systemctl --user status";
-    watch = "watch --color";
+    watch = "watch --color --differences";
+    yt = "yt-dlp";
     zfs-umount = "zfs-unmount";
   };
   initExtra = ''
     shopt -s globstar
+    shopt -s histreedit
+    shopt -s histverify
     # Disable ctrl-s/ctrl-q flow control
     stty -ixon
 
@@ -102,7 +110,7 @@ programs.bash = {
   '';
 };
 programs.direnv.enableBashIntegration = true;
-programs.broot.enableBashIntegration = true;
+#programs.broot.enableBashIntegration = true;
 home.sessionVariables = {
   PS1 = ''\[\033[1;32m\]\[\e]0;\u@\h: \w\a\]\W\[\033[0m\] \$(e=\$?; if [ \$e != 0 ]; then echo '\[\e[0;91m\]'\$e'\[\e[0m\]'; fi)\$ '';
 };