{ pkgs, lib, config, options, ... }:
{
config = {
+/*
home.activation.gnupg = lib.hm.dag.entryAfter ["writeBoundary"] ''
- install -d -m700 ${lib.escapeShellArg config.home.homeDirectory}/.gnupg
-'';
-home.file.".gnupg/dirmngr.conf".text = ''
- allow-ocsp
- hkp-cacert ${gnupg/keyserver.pem}
- keyserver hkps://keys.mayfirst.org
- #use-tor
- #log-file dirmngr.log
- #standard-resolver
+ install -d -m700 ${lib.escapeShellArg config.programs.gpg.homedir}
'';
+*/
services.gpg-agent = {
enableSshSupport = true;
+ enableExtraSocket = true;
pinentryFlavor = if config.host.desktop then "gtk2" else "curses";
};
programs.gpg.settings = {
use-agent = true;
utf8-strings = true;
};
+home.file."${config.programs.gpg.homedir}/dirmngr.conf".text = ''
+ allow-ocsp
+ hkp-cacert ${gnupg/keyserver.pem}
+ keyserver hkps://keys.mayfirst.org
+ #use-tor
+ #log-file dirmngr.log
+ #standard-resolver
+'';
} // lib.optionalAttrs (options ? "nixpkgs") {
nixpkgs.overlays = [ (self: super: {
# Avoid rebuilding graphical dependencies