nix: add input nixos-hardware
[julm/julm-nix.git] / nixos / profiles / networking / ssh.nix
index d37e2952ee1294681597e282a3f6f9eb009dccd1..4ab5add2ea6fc55a4994ad62fa2a3d9a17842365 100644 (file)
@@ -3,11 +3,9 @@ with lib;
 {
   programs.mosh.enable = mkDefault true;
   services.openssh.enable = true;
-  systemd.services.sshd.serviceConfig.LoadCredentialEncrypted =
-    [ "ed25519.key:${inputs.self}/hosts/${hostName}/networking/ssh/ed25519.key.cred" ];
   # TODO: use hostKeys= once LoadCredentialEncrypted= works in ExecStartPre=
-  services.openssh.hostKeys = mkForce [];
+  services.openssh.hostKeys = mkForce [ ];
   services.openssh.extraConfig = ''
-    HostKey /run/credentials/sshd.service/ed25519.key
+    HostKey /run/credentials/sshd.service/host.key
   '';
 }