git: tweak config
[julm/julm-nix.git] / nixos / profiles / networking / ssh.nix
index d37e2952ee1294681597e282a3f6f9eb009dccd1..d3fee5925877fcd673891e4e9655be17e89a3b2d 100644 (file)
@@ -1,13 +1,16 @@
-{ lib, inputs, hostName, ... }:
+{
+  lib,
+  inputs,
+  hostName,
+  ...
+}:
 with lib;
 {
   programs.mosh.enable = mkDefault true;
   services.openssh.enable = true;
-  systemd.services.sshd.serviceConfig.LoadCredentialEncrypted =
-    [ "ed25519.key:${inputs.self}/hosts/${hostName}/networking/ssh/ed25519.key.cred" ];
   # TODO: use hostKeys= once LoadCredentialEncrypted= works in ExecStartPre=
-  services.openssh.hostKeys = mkForce [];
+  services.openssh.hostKeys = mkForce [ ];
   services.openssh.extraConfig = ''
-    HostKey /run/credentials/sshd.service/ed25519.key
+    HostKey /run/credentials/sshd.service/host.key
   '';
 }