wine: add profile
[julm/julm-nix.git] / nixos / profiles / hardware / apu6b4.nix
index 268b8c32d47a1fd3fb964b68bd1b1163320e9df4..6ab46c265a4369b83930689cce2380e95f9ccb2d 100644 (file)
@@ -1,4 +1,9 @@
-{ pkgs, lib, ... }:
+{
+  pkgs,
+  lib,
+  config,
+  ...
+}:
 with lib;
 {
 
@@ -7,10 +12,10 @@ with lib;
     config = "x86_64-unknown-linux-gnu";
   };
   _module.args.CPUs = 4;
-  hardware.cpu.amd.updateMicrocode = true;
+  hardware.cpu.amd.updateMicrocode = mkDefault config.hardware.enableRedistributableFirmware;
   powerManagement.cpuFreqGovernor = mkDefault "ondemand";
 
-  # Too CPU hungry for this hardware, for too little Mio saved
+  # Too CPU hungry for this hardware, for too little MiB saved
   nix.settings.auto-optimise-store = false;
 
   # https://insanity.industries/post/sata-power-consumption/
@@ -21,7 +26,6 @@ with lib;
   boot.loader = {
     grub = {
       enable = true;
-      version = 2;
       copyKernels = true;
       configurationLimit = mkDefault 1;
       # efiSupport = true;
@@ -31,11 +35,11 @@ with lib;
         # Completed in the importing configuration
       ];
       /*
-        mirroredBoots = [
-      { devices = [ "${disk_id}" ];
-        path    = "/boot${bootnum}";
-      }
-        ];
+          mirroredBoots = [
+        { devices = [ "${disk_id}" ];
+          path    = "/boot${bootnum}";
+        }
+          ];
       */
     };
     /*