pumpkin: ffmpeg: enable VMAF
[julm/julm-nix.git] / home-manager / profiles / git.nix
index 8b54fb163d3e145157df48865092e12d1e9e49ac..677f4a68a6340329c5dcea9c104c96f9fbb00884 100644 (file)
       ign = "ls-files -o -i --exclude-standard";
       l = "log";
       ll = "log --graph --decorate --pretty=oneline --abbrev-commit";
-      lp = "log -p --pretty=fuller";
-      lpg = "log -p --pretty=fuller -g";
+      lp = "log -p --pretty=fuller --stat";
+      lpg = "log -p --pretty=fuller --stat -g";
       p = "push -v";
       pa = "patch";
       patch = "push rad HEAD:refs/patches";
-      pf = "push -vf";
+      # See https://stackoverflow.com/a/65839129/6741004
+      pf = "push -v --force-with-lease --force-if-includes";
       pl = "pull";
       r = "reset";
       rh = "reset --hard";
@@ -64,6 +65,7 @@
       spush = "!git-svn dcommit";
       ss = "status -s";
       st = "status -uno";
+      stu = "status -unormal";
       sw = "switch";
       fetch-local = "!git fetch local && git tag -d $(git describe --exact-match 2>/dev/null >/dev/null) && git fetch --tags local";
       pull-local = "!git fetch-local && git checkout -B master local/master";
       protocol.version = 2;
       pull.rebase = true;
       push.default = "simple";
+      push.useForceIfIncludes = true;
       rebase.autosquash = "true";
       sendemail.chainReplyTo = "false";
       sendemail.composeencoding = "UTF-8";