-{ pkgs, lib, config, ... }:
+{ pkgs, config, ... }:
{
-home.file.".xmonad/xmobar.hs".source = xmonad/xmobar.hs;
-xsession = {
- enable = true;
- scriptPath = ".hm-xsession";
- initExtra = ''
- xset dpms 380 640 1200
- ${pkgs.xorg.xsetroot}/bin/xsetroot -solid black -fg black -bg white -cursor_name left_ptr
- ${pkgs.rxvt-unicode}/bin/urxvtd -f -o
- ${pkgs.copyq}/bin/copyq &
- ${pkgs.pasystray}/bin/pasystray &
- '';
- windowManager.xmonad = {
+ imports = [
+ ./clipster.nix
+ ];
+ home.file.".xmonad/xmobar.hs".source = xmonad/xmobar.hs;
+ xsession = {
enable = true;
- haskellPackages = pkgs.haskellPackages;
- extraPackages = haskellPackages: [
- haskellPackages.data-default
- ];
- enableContribAndExtras = true;
- config = xmonad/xmonad.hs;
+ scriptPath = ".hm-xsession";
+ initExtra = ''
+ xset dpms 380 640 1200
+ ${pkgs.xorg.xsetroot}/bin/xsetroot -solid black -fg black -bg white -cursor_name left_ptr
+ ${pkgs.rxvt-unicode}/bin/urxvtd -f -o
+ ${pkgs.pasystray}/bin/pasystray &
+ '';
+ windowManager.xmonad = {
+ enable = true;
+ inherit (pkgs) haskellPackages;
+ extraPackages = haskellPackages: [
+ haskellPackages.data-default
+ ];
+ enableContribAndExtras = true;
+ config = xmonad/xmonad.hs;
+ };
+ };
+ home.packages = [
+ pkgs.acpilight
+ pkgs.ffmpegthumbnailer
+ pkgs.gmrun
+ pkgs.light
+ #pkgs.gnome.nautilus
+ #pkgs.gtk3
+ pkgs.mate.caja-with-extensions
+ #(pkgs.writeShellScriptBin "mate-terminal" ''exec ${pkgs.rxvt-unicode}/bin/urxvtc -hold "$@"'')
+ pkgs.rofi
+ pkgs.scrot
+ pkgs.stalonetray
+ pkgs.wmname
+ pkgs.xmobar
+ pkgs.xorg.appres
+ pkgs.xorg.xev
+ pkgs.xorg.xhost
+ pkgs.xorg.xmodmap
+ pkgs.xorg.xset
+ ];
+ xresources.properties = {
+ "Xft.antialias" = true;
+ "Xft.hinting" = true;
+ "Xft.hintstyle" = "hintfull";
+ "Xft.rgba" = "rgb";
+ #"Xft.embolden" = true;
};
-};
-home.packages = [
- pkgs.acpilight
- pkgs.copyq
- pkgs.ffmpegthumbnailer
- pkgs.gmrun
- pkgs.light
- pkgs.mate.caja-with-extensions
- (pkgs.writeShellScriptBin "mate-terminal" ''exec ${pkgs.rxvt-unicode}/bin/urxvtc -hold "$@"'')
- pkgs.scrot
- pkgs.stalonetray
- pkgs.wmname
- pkgs.xmobar
- pkgs.xorg.appres
- pkgs.xorg.xev
- pkgs.xorg.xhost
- pkgs.xorg.xmodmap
- pkgs.xorg.xset
-];
-xresources.properties = {
- "Xft.antialias" = true;
- "Xft.hinting" = true;
- "Xft.hintstyle" = "hintfull";
- "Xft.rgba" = "rgb";
- #"Xft.embolden" = true;
-};
}