git: enable zdiff3
[julm/julm-nix.git] / nixos / profiles / security.nix
index 1935b56dfa6ec9ba80a4651ed3b3601a19bc4af3..f5a6c543ded3b1d4005a1129c9f2199a6ab683cb 100644 (file)
@@ -180,6 +180,14 @@ with lib;
     };
     openFirewall = mkDefault false;
     settings = {
+      Ciphers = [
+        # Not hardware accelerated, but fast enough and somehow more secure
+        # (packet sizes are encrypted and less vulnerable to timing attacks).
+        "chacha20-poly1305@openssh.com"
+        # A bit more throughput.
+        "aes128-gcm@openssh.com"
+        "aes256-gcm@openssh.com"
+      ];
       KbdInteractiveAuthentication = mkDefault false;
       # Use key exchange algorithms recommended by `nixpkgs#ssh-audit`
       KexAlgorithms = [