pastel: enable on essential profile
[julm/julm-nix.git] / hosts / aubergine / networking / wifi.nix
index ec7fbb456d21e44285698c7d082e39cd497329b0..19d8e34530cc42bf1b9c59a01093e28294aa1414 100644 (file)
@@ -1,4 +1,9 @@
-{ pkgs, lib, hostName, ... }:
+{
+  pkgs,
+  lib,
+  hostName,
+  ...
+}:
 with (import ./names-and-numbers.nix);
 with (import ./names-and-numbers.nix.clear);
 {
@@ -71,10 +76,11 @@ with (import ./names-and-numbers.nix.clear);
         countryCode = "FR";
         networks.${wifiIface} = {
           ssid = hostName;
-          ignoreBroadcastSsid = "empty";
+          #ignoreBroadcastSsid = "clear";
           authentication = {
             # FIXME: use wpa3-sae
             mode = "wpa2-sha256";
+            #mode = "none";
             # FIXME: use wpaPasswordFile or saePasswordsFile
             wpaPassword = wpaPassphrase;
           };