blackberry: enable tor
[julm/julm-nix.git] / nixos / profiles / networking / remote.nix
index 5bfa521b9efc1a6dae491c77456c37dfe73d58af..b0f6b3695a01b2a38ce37733fc397992bab7e1db 100644 (file)
@@ -13,7 +13,7 @@ with lib;
   # sets this up as soon as the initrd.
   boot.kernelParams = [ "panic=10" ];
 
-  programs.gnupg.agent.pinentryFlavor = "curses";
+  programs.gnupg.agent.pinentryPackage = pkgs.pinentry-curses;
 
   systemd = {
     # Always try to start all the units (default.target)
@@ -32,10 +32,5 @@ with lib;
     # hangs without progress for more than 120s.
     # See https://utcc.utoronto.ca/~cks/space/blog/linux/SystemdShutdownWatchdog
     watchdog.rebootTime = mkDefault "120s";
-
-    sleep.extraConfig = ''
-      AllowSuspend=no
-      AllowHibernation=no
-    '';
   };
 }