bash: alias lst
[julm/julm-nix.git] / hosts / aubergine / networking.nix
index 8184ce6b01ac9a362e3233b143f6a0e113f2b6c2..e1d6955230e61b66f5d7f24b8a3191658708dd20 100644 (file)
@@ -8,9 +8,7 @@ with (import networking/names-and-numbers.nix);
     networking/wifi.nix
     networking/lte.nix
     networking/nftables.nix
-    ./wireguard.nix
     ../../nixos/profiles/dnscrypt-proxy2.nix
-    ../../nixos/profiles/wireguard/wg-intra.nix
     ../../nixos/profiles/networking/ssh.nix
   ];
   install.substituteOnDestination = false;
@@ -38,9 +36,20 @@ with (import networking/names-and-numbers.nix);
     }
   '';
 
-  services.avahi.enable = true;
-  services.avahi.openFirewall = true;
-  services.avahi.publish.enable = true;
+  networking.networkmanager.enable = true;
+  services.avahi = {
+    enable = true;
+    openFirewall = true;
+    nssmdns4 = true;
+    publish = {
+      enable = true;
+      addresses = true;
+      domain = true;
+      hinfo = true;
+      userServices = true;
+      workstation = true;
+    };
+  };
   # WARNING: settings.listen_addresses are not merged...
   # hence there all defined here.
   services.dnscrypt-proxy2.settings.listen_addresses = [