git: ignore formatting with nixfmt-rfc-style
[julm/julm-nix.git] / hosts / aubergine / hardware.nix
index 62da31c3c9405fb04d4088b27bcc9a7205becf7b..5feeaa03a9824892f45b06e6b3414425cb30cead 100644 (file)
@@ -1,4 +1,9 @@
-{ pkgs, lib, hostName, ... }:
+{
+  pkgs,
+  lib,
+  hostName,
+  ...
+}:
 {
   imports = [
     ../../nixos/profiles/hardware/apu6b4.nix
     #enableCryptodisk = true;
   };
 
-  boot.supportedFilesystems = [ /*"ntfs"*/ "vfat" ];
+  boot.supportedFilesystems = [
+    # "ntfs"
+    "vfat"
+  ];
   boot.extraModulePackages = [
     #config.boot.kernelPackages.exfat-nofuse
   ];
 
   #services.fprintd.enable = true;
 
-  fileSystems."/" =
-    {
-      device = "${hostName}/root";
-      fsType = "zfs";
-    };
-  fileSystems."/boot" =
-    {
-      device = "/dev/disk/by-partlabel/${hostName}_ssd_boot";
-      fsType = "ext4";
-    };
-  fileSystems."/boot/efi" =
-    {
-      device = "/dev/disk/by-partlabel/${hostName}_ssd_efi";
-      fsType = "vfat";
-    };
-  fileSystems."/nix" =
-    {
-      device = "${hostName}/nix";
-      fsType = "zfs";
-    };
-  fileSystems."/var" =
-    {
-      device = "${hostName}/var";
-      fsType = "zfs";
-    };
-  fileSystems."/home" =
+  fileSystems."/" = {
+    device = "${hostName}/root";
+    fsType = "zfs";
+  };
+  fileSystems."/boot" = {
+    device = "/dev/disk/by-partlabel/${hostName}_ssd_boot";
+    fsType = "ext4";
+  };
+  fileSystems."/boot/efi" = {
+    device = "/dev/disk/by-partlabel/${hostName}_ssd_efi";
+    fsType = "vfat";
+  };
+  fileSystems."/nix" = {
+    device = "${hostName}/nix";
+    fsType = "zfs";
+  };
+  fileSystems."/var" = {
+    device = "${hostName}/var";
+    fsType = "zfs";
+  };
+  fileSystems."/home" = {
+    device = "${hostName}/home";
+    fsType = "zfs";
+  };
+  swapDevices = [
     {
-      device = "${hostName}/home";
-      fsType = "zfs";
-    };
-  swapDevices =
-    [
-      {
-        device = "/dev/disk/by-partlabel/${hostName}_ssd_swap";
-        randomEncryption = {
-          enable = true;
-          cipher = "aes-xts-plain64";
-          source = "/dev/urandom";
-        };
-      }
-    ];
+      device = "/dev/disk/by-partlabel/${hostName}_ssd_swap";
+      randomEncryption = {
+        enable = true;
+        cipher = "aes-xts-plain64";
+        source = "/dev/urandom";
+      };
+    }
+  ];
 
 }