home: zfs: import some disks when plugged-in
[julm/julm-nix.git] / home-manager / profiles / graphical.nix
index 1585e597309294ea7b03faf52935a794e8be3542..bf5d874c136d5cdecc6c7c23d0d9f512264b63d7 100644 (file)
@@ -3,12 +3,11 @@
   imports = [
     ./redshift.nix
   ];
-  gtk.enable = true;
   home.packages = [
     pkgs.arandr
     pkgs.glib.bin
     pkgs.glxinfo
-    pkgs.gnome.dconf-editor
+    pkgs.dconf-editor
     pkgs.hicolor-icon-theme
     pkgs.pavucontrol
     pkgs.qpwgraph
@@ -20,7 +19,7 @@
   home.sessionVariables = lib.mkIf (!nixosConfig.services.gnome.at-spi2-core.enable) {
     NO_AT_BRIDGE = "1";
   };
-  services.redshift.enable = lib.mkDefault true;
+  # keycode <num> = <x> <Shift+x> _ _ <AltGr+x> <AltGr+Shift+x> _ _"
   home.file.".Xmodmap".text = ''
     ! — (tiret insécable) with AltGr+Shift+-
     keycode 15 = minus                6            bar       fiveeighths bar         U2011
     ! œ with AltGr+o
     ! Œ with AltGr+Shift+o
     keycode 32 = o                    O            o         O           oe          OE
-    ! … (ellipsis) with AltGr+
+    ! … (ellipsis) with AltGr+;
     keycode 59 = semicolon period comma less ellipsis multiply ccedilla Ccedilla
+    !   (nbsp) with AltGr+space and   (narrow nbsp) with AltGr+Shift+space
+    keycode 65 = space space NoSymbol NoSymbol nobreakspace U202F
   '';
   systemd.user.services.setxkbmap.Service.ExecStartPost =
     "${pkgs.xorg.xmodmap}/bin/xmodmap ${config.home.homeDirectory}/.Xmodmap";
   };
   dconf.settings = {
     "org/gnome/desktop/interface" = {
-      color-scheme = "prefer-dark";
+      color-scheme = lib.mkDefault "prefer-dark";
     };
   };
   gtk = {
+    enable = lib.mkDefault true;
     theme.name = "Adwaita";
+    theme.package = pkgs.gnome-themes-extra;
+    iconTheme.package = pkgs.adwaita-icon-theme;
+    iconTheme.name = "Adwaita";
     gtk2.configLocation = "${config.xdg.configHome}/gtk-2.0/gtkrc";
     gtk3 = {
       bookmarks = lib.mkDefault [