blender: use the 2.93 alpha release for LineArt
[julm/julm-nix.git] / hosts / patate.nix
index fa0ed57e0b7221ab5be9af53c038d39a436dbc43..4e229446996d7d2ad5ba7e500c1ce1315e82d872 100644 (file)
@@ -21,7 +21,7 @@ users.users.sevy = {
   uid = 1000;
   # Put the hashedPassword in /nix/store, but it will also be in /etc/passwd
   # which is already world readable.
-  hashedPassword = lib.readFile ../secrets/sevy/hashedPassword;
+  hashedPassword = lib.readFile ../private/world/sevy/hashedPassword;
   extraGroups = [
     "adbusers"
     "lp"
@@ -49,13 +49,23 @@ nix = {
     "nixpkgs-overlays=/etc/nixpkgs-overlays/overlays.nix"
   ];
   trustedUsers = [ users.sevy.name ];
+  binaryCaches = [
+    "https://nix-localcache.sourcephile.fr"
+    "ssh://nix-ssh@192.168.0.115" # FIXME: use wireguard
+  ];
+  binaryCachePublicKeys = [
+    "losurdo.sourcephile.fr-1:XGeaIE2AA2mZskSZ5bIDrfx53q+TDDWJOUEpZDX7los="
+    "oignon.sourcephile.fr:slxL7XLsGXlD1r6gvw1imL5uQntW0TTlQgGQt3LBJgQ="
+  ];
 };
-environment.etc."nixpkgs".source = pkgs.path;
-environment.etc."nixpkgs-overlays".source = inputs.self + "/nixpkgs";
+services.openssh.passwordAuthentication = false;
 
 nixpkgs.config = {
   allowUnfree = true;
 };
+environment.etc."nixpkgs".source = pkgs.path;
+environment.etc."nixpkgs-overlays".source = inputs.self + "/nixpkgs";
+
 documentation.nixos.enable = true;
 time.timeZone = "Europe/Paris";
 i18n.defaultLocale = "fr_FR.UTF-8";
@@ -77,6 +87,7 @@ networking = {
   };
   firewall = {
     enable = true;
+    allowPing = false;
     allowedTCPPorts = [
       51413 # transmission-gtk
       4662 # edonkey
@@ -149,6 +160,10 @@ services = {
   avahi = {
     enable  = true;
     nssmdns = true;
+    openFirewall = false;
+    publish = {
+      enable = false;
+    };
   };
   dbus = {
     packages = [ pkgs.gnome3.dconf ];