-{ config, pkgs, lib, inputs, hostName, ... }:
+{
+ config,
+ pkgs,
+ lib,
+ inputs,
+ hostName,
+ ...
+}:
{
imports = [
#../nixos/profiles/debug.nix
#../nixos/profiles/radio.nix
../nixos/profiles/tor.nix
../nixos/profiles/bluetooth.nix
+ ../nixos/profiles/home.nix
#blackberry/backup.nix
blackberry/hardware.nix
blackberry/nebula.nix
};
nix = {
- extraOptions = ''
- '';
+ extraOptions = '''';
settings = {
substituters = [
];
programs.fuse.userAllowOther = true;
systemd.automounts = [
- { where = "/mnt/aubergine"; automountConfig.TimeoutIdleSec = "5 min"; }
+ {
+ where = "/mnt/aubergine";
+ automountConfig.TimeoutIdleSec = "5 min";
+ }
];
fileSystems =
let
# Use the user's gpg-agent session to query
# for the password of the SSH key when auto-mounting.
- sshAsUser =
- pkgs.writeScript "sshAsUser" ''
- user="$1"; shift
- exec ${pkgs.sudo}/bin/sudo -i -u "$user" \
- ${pkgs.openssh}/bin/ssh "$@"
- '';
- options =
- [
- "user"
- "uid=julm"
- "gid=users"
- "allow_other"
- "exec" # Override "user"'s noexec
- "noatime"
- "nosuid"
- "_netdev"
- "ssh_command=${sshAsUser}\\040julm"
- "noauto"
- "x-gvfs-hide"
- "x-systemd.automount"
- #"Compression=yes" # YMMV
- # Disconnect approximately 2*15=30 seconds after a network failure
- "ServerAliveCountMax=1"
- "ServerAliveInterval=15"
- "dir_cache=no"
- #"reconnect"
- ];
+ sshAsUser = pkgs.writeScript "sshAsUser" ''
+ user="$1"; shift
+ exec ${pkgs.sudo}/bin/sudo -i -u "$user" \
+ ${pkgs.openssh}/bin/ssh "$@"
+ '';
+ options = [
+ "user"
+ "uid=julm"
+ "gid=users"
+ "allow_other"
+ "exec" # Override "user"'s noexec
+ "noatime"
+ "nosuid"
+ "_netdev"
+ "ssh_command=${sshAsUser}\\040julm"
+ "noauto"
+ "x-gvfs-hide"
+ "x-systemd.automount"
+ #"Compression=yes" # YMMV
+ # Disconnect approximately 2*15=30 seconds after a network failure
+ "ServerAliveCountMax=1"
+ "ServerAliveInterval=15"
+ "dir_cache=no"
+ #"reconnect"
+ ];
in
{
"/mnt/aubergine" = {