zfs: add lzop and mbuffer
[julm/julm-nix.git] / hosts / aubergine / networking.nix
index 201b1cef89a31b03fc9dcd235831c2dc7537ef51..f382723c6c86830224d939b4192276eb1c89ddf0 100644 (file)
@@ -8,7 +8,7 @@ with (import networking/names-and-numbers.nix);
     networking/wifi.nix
     networking/lte.nix
     networking/nftables.nix
-    wireguard/wg-intra.nix
+    ./wireguard.nix
     ../../nixos/profiles/dnscrypt-proxy2.nix
     ../../nixos/profiles/wireguard/wg-intra.nix
     ../../nixos/profiles/networking/ssh.nix
@@ -20,6 +20,10 @@ with (import networking/names-and-numbers.nix);
   boot.kernel.sysctl."net.ipv4.ip_forward" = 1;
   networking.nftables.ruleset = mkAfter ''
     table inet filter {
+      chain forward-to-lan {
+        #jump forward-connectivity
+        counter accept
+      }
       chain forward-to-net {
         #jump forward-connectivity
         counter accept
@@ -49,4 +53,8 @@ with (import networking/names-and-numbers.nix);
   ];
 
   services.vnstat.enable = true;
+
+  systemd.services.sshd.serviceConfig.LoadCredentialEncrypted = [
+    "host.key:${ssh/host.key.cred}"
+  ];
 }