aubergine: creds: add ssh host key
[julm/julm-nix.git] / home-manager / options.nix
index e8dd0d33180631f7d9704caa07821cc6c2d7bbfa..847772b8441728649a71211723f451bbf4c22365 100644 (file)
@@ -1,15 +1,7 @@
-{ pkgs, lib, config, ... }:
+{ config, ... }:
 with builtins;
 {
-options.host = {
-  hardware = lib.mkOption {
-    type = with lib.types; listOf str;
-    default = filter (x: isString x && x != "") (split "[ \n]+" (readFile
-      "/sys/devices/virtual/dmi/id/product_name"));
-    description = "hardware";
+  config = {
+    home.stateVersion = "20.09";
   };
-};
-config = {
-  home.stateVersion = "20.09";
-};
 }