-{ pkgs, lib, ... }:
+{ pkgs, lib, config, ... }:
with lib;
{
config = "x86_64-unknown-linux-gnu";
};
_module.args.CPUs = 4;
- hardware.cpu.amd.updateMicrocode = true;
+ hardware.cpu.amd.updateMicrocode = mkDefault config.hardware.enableRedistributableFirmware;
powerManagement.cpuFreqGovernor = mkDefault "ondemand";
- # Too CPU hungry for this hardware, for too little Mio saved
+ # Too CPU hungry for this hardware, for too little MiB saved
nix.settings.auto-optimise-store = false;
# https://insanity.industries/post/sata-power-consumption/