aubergine: nftables: fix DHCP renewal
[julm/julm-nix.git] / nixos / profiles / hardware / apu6b4.nix
index 82c537a5946ddd2c2d33e1a77ae2ac332f8cbfd8..7dced5c54f02551e7f84ddc8d5bf3a66857ef077 100644 (file)
@@ -1,4 +1,4 @@
-{ pkgs, lib, ... }:
+{ pkgs, lib, config, ... }:
 with lib;
 {
 
@@ -7,10 +7,10 @@ with lib;
     config = "x86_64-unknown-linux-gnu";
   };
   _module.args.CPUs = 4;
-  hardware.cpu.amd.updateMicrocode = true;
+  hardware.cpu.amd.updateMicrocode = mkDefault config.hardware.enableRedistributableFirmware;
   powerManagement.cpuFreqGovernor = mkDefault "ondemand";
 
-  # Too CPU hungry for this hardware, for too little Mio saved
+  # Too CPU hungry for this hardware, for too little MiB saved
   nix.settings.auto-optimise-store = false;
 
   # https://insanity.industries/post/sata-power-consumption/