aubergine: upgrade to nixos-23.11
[julm/julm-nix.git] / hosts / oignon / hardware.nix
index 21341be715342323cbd348b2b3403bf4738ec82f..91e94c2924e702ebb868d7e9aff8f7784f007eed 100644 (file)
     #efiSupport = true;
     #enableCryptodisk = true;
   };
+  boot.zfs.requestEncryptionCredentials = [ hostName ];
+
+  hardware.enableRedistributableFirmware = true;
 
   # Note that gobi_loader -2000 has to be rerun if the SIM is hot swapped
   services.udev.extraRules = ''
-    ACTION=="add", SUBSYSTEM=="tty", KERNEL=="ttyUSB*", ATTRS{idVendor}=="05c6", ATTRS{idProduct}=="9204", RUN+="${pkgs.gobi_loader}/lib/udev/gobi_loader -2000 $env{DEVNAME} /home/julm/documents/thinkpad-x201/gobi"
+    ACTION=="add", SUBSYSTEM=="tty", KERNEL=="ttyUSB*", ATTRS{idVendor}=="05c6", ATTRS{idProduct}=="9204", RUN+="${pkgs.gobi_loader}/lib/udev/gobi_loader -2000 $env{DEVNAME} /home/julm/files/thinkpad-x201/gobi"
   '';
 
   fileSystems."/boot" =