nix: update to nixos-23.11
[julm/julm-nix.git] / hosts / aubergine / hardware.nix
index 2d70a97cb08ddc74ac31e44c128d72184aa19e9a..0f6d90f97c93146344aa95f1316dae81a7e9acf5 100644 (file)
@@ -1,8 +1,9 @@
-{ lib, hostName, ... }:
+{ pkgs, lib, hostName, ... }:
 {
   imports = [
     ../../nixos/profiles/hardware/apu6b4.nix
     ../../nixos/profiles/hardware/ME909u-521.nix
+    ../../nixos/profiles/serial.nix
     ../../nixos/profiles/zfs.nix
     ../../nixos/profiles/zramSwap.nix
   ];
     #efiSupport = true;
     #enableCryptodisk = true;
   };
-  boot.tmp.useTmpfs = true;
 
   boot.supportedFilesystems = [ /*"ntfs"*/ "vfat" ];
   boot.extraModulePackages = [
     #config.boot.kernelPackages.exfat-nofuse
   ];
+  boot.zfs.requestEncryptionCredentials = [ hostName ];
+
+  hardware.enableRedistributableFirmware = true;
 
   powerManagement.powertop.enable = true;
+
   #services.fprintd.enable = true;
 
   fileSystems."/" =