pumpkin: steam-run: install
[julm/julm-nix.git] / hosts / aubergine / hardware.nix
index 2d70a97cb08ddc74ac31e44c128d72184aa19e9a..5feeaa03a9824892f45b06e6b3414425cb30cead 100644 (file)
@@ -1,10 +1,17 @@
-{ lib, hostName, ... }:
+{
+  pkgs,
+  lib,
+  hostName,
+  ...
+}:
 {
   imports = [
     ../../nixos/profiles/hardware/apu6b4.nix
     ../../nixos/profiles/hardware/ME909u-521.nix
+    ../../nixos/profiles/serial.nix
     ../../nixos/profiles/zfs.nix
     ../../nixos/profiles/zramSwap.nix
+    ../../nixos/profiles/pipewire.nix
   ];
 
   # Setting the machine-id avoids to reencrypt all credentials
     #efiSupport = true;
     #enableCryptodisk = true;
   };
-  boot.tmp.useTmpfs = true;
 
-  boot.supportedFilesystems = [ /*"ntfs"*/ "vfat" ];
+  boot.supportedFilesystems = [
+    # "ntfs"
+    "vfat"
+  ];
   boot.extraModulePackages = [
     #config.boot.kernelPackages.exfat-nofuse
   ];
+  boot.zfs.requestEncryptionCredentials = [ hostName ];
+
+  hardware.enableRedistributableFirmware = true;
 
   powerManagement.powertop.enable = true;
+
   #services.fprintd.enable = true;
 
-  fileSystems."/" =
-    {
-      device = "${hostName}/root";
-      fsType = "zfs";
-    };
-  fileSystems."/boot" =
-    {
-      device = "/dev/disk/by-partlabel/${hostName}_ssd_boot";
-      fsType = "ext4";
-    };
-  fileSystems."/boot/efi" =
-    {
-      device = "/dev/disk/by-partlabel/${hostName}_ssd_efi";
-      fsType = "vfat";
-    };
-  fileSystems."/nix" =
-    {
-      device = "${hostName}/nix";
-      fsType = "zfs";
-    };
-  fileSystems."/var" =
-    {
-      device = "${hostName}/var";
-      fsType = "zfs";
-    };
-  fileSystems."/home" =
+  fileSystems."/" = {
+    device = "${hostName}/root";
+    fsType = "zfs";
+  };
+  fileSystems."/boot" = {
+    device = "/dev/disk/by-partlabel/${hostName}_ssd_boot";
+    fsType = "ext4";
+  };
+  fileSystems."/boot/efi" = {
+    device = "/dev/disk/by-partlabel/${hostName}_ssd_efi";
+    fsType = "vfat";
+  };
+  fileSystems."/nix" = {
+    device = "${hostName}/nix";
+    fsType = "zfs";
+  };
+  fileSystems."/var" = {
+    device = "${hostName}/var";
+    fsType = "zfs";
+  };
+  fileSystems."/home" = {
+    device = "${hostName}/home";
+    fsType = "zfs";
+  };
+  swapDevices = [
     {
-      device = "${hostName}/home";
-      fsType = "zfs";
-    };
-  swapDevices =
-    [
-      {
-        device = "/dev/disk/by-partlabel/${hostName}_ssd_swap";
-        randomEncryption = {
-          enable = true;
-          cipher = "aes-xts-plain64";
-          source = "/dev/urandom";
-        };
-      }
-    ];
-
-  hardware.pulseaudio.enable = lib.mkDefault true;
-  #hardware.pulseaudio.tcp.enable = lib.mkDefault true;
+      device = "/dev/disk/by-partlabel/${hostName}_ssd_swap";
+      randomEncryption = {
+        enable = true;
+        cipher = "aes-xts-plain64";
+        source = "/dev/urandom";
+      };
+    }
+  ];
 
 }