oignon: rtl-sdr: add support
[julm/julm-nix.git] / flake.nix
index 4204cf4f283526d4e687705259b4f7351431d6d3..ad7577c951bc13be6fdf2703ffe8b0cab51f1650 100644 (file)
--- a/flake.nix
+++ b/flake.nix
 {
-inputs.nixpkgs.url = "github:NixOS/nixpkgs/062a0c5437b68f950b081bbfc8a699d57a4ee026";
-inputs.flake-utils.url = "github:numtide/flake-utils";
-inputs.home-manager.url = "github:nix-community/home-manager";
-inputs.home-manager.inputs.nixpkgs.follows = "nixpkgs";
-inputs.doom-emacs.url = "github:hlissner/doom-emacs";
-inputs.doom-emacs.flake = false;
-inputs.nix-doom-emacs.url = "github:vlaci/nix-doom-emacs";
-inputs.nix-doom-emacs.inputs.nixpkgs.follows = "nixpkgs";
-inputs.nix-doom-emacs.inputs.home-manager.follows = "home-manager";
-inputs.nix-doom-emacs.inputs.flake-utils.follows = "flake-utils";
-inputs.nix-doom-emacs.inputs.emacs-overlay.follows = "emacs-overlay";
-inputs.emacs-overlay.url = "github:nix-community/emacs-overlay/master";
-#inputs.pass = { type = "path"; path = "./pass"; flake = false; };
-
-outputs = inputs: let
-  remoteNixpkgsPatches = import nixpkgs/patches.nix;
-  localNixpkgsPatches = [
-  ];
-  originPkgs = inputs.nixpkgs.legacyPackages."x86_64-linux";
-  nixpkgsPath = originPkgs.applyPatches {
-    name = "nixpkgs-patched";
-    src = inputs.nixpkgs.outPath;
-    patches = map originPkgs.fetchpatch remoteNixpkgsPatches ++ localNixpkgsPatches;
-    postPatch = ''
-      patch=$(printf '%s\n' ${builtins.concatStringsSep " "
-         (map (p: p.sha256) remoteNixpkgsPatches ++ localNixpkgsPatches)} |
-        sort | sha256sum | cut -c -7)
-      echo "+patch-$patch" >.version-suffix
-    '';
+  inputs = {
+    doom-emacs.flake = false;
+    doom-emacs.url = "github:hlissner/doom-emacs";
+    home-manager.inputs.nixpkgs.follows = "nixpkgs";
+    home-manager.url = "github:nix-community/home-manager/release-23.05";
+    nix-formatter-pack.inputs.nixpkgs.follows = "nixpkgs";
+    nix-formatter-pack.url = "github:Gerschtli/nix-formatter-pack";
+    nixpkgs.url = "github:NixOS/nixpkgs/release-23.05";
+    pre-commit-hooks.inputs.nixpkgs.follows = "nixpkgs";
+    pre-commit-hooks.inputs.nixpkgs-stable.follows = "nixpkgs";
+    pre-commit-hooks.url = "github:cachix/pre-commit-hooks.nix";
   };
-  lib = originPkgs.lib;
-  nixosSystem = import (nixpkgsPath + "/nixos/lib/eval-config.nix");
-  #nixosSystem = inputs.nixpkgs.lib.nixosSystem;
-  in {
-  nixosConfigurations = lib.genAttrs
-    (builtins.attrNames (lib.filterAttrs (n: v: v == "directory") (builtins.readDir ./hosts)))
-    (hostName: nixosSystem rec {
-      system = "x86_64-linux";
-      specialArgs = {
-        inherit hostName inputs;
-        private = "/root/private"; # Kept out of /nix/store
+
+  outputs = inputs:
+    let
+      remoteNixpkgsPatches = import nixpkgs/patches.nix;
+      localNixpkgsPatches = [
+      ];
+      originPkgs = inputs.nixpkgs.legacyPackages."x86_64-linux";
+      nixpkgsPath = originPkgs.applyPatches {
+        name = "nixpkgs-patched";
+        src = inputs.nixpkgs.outPath;
+        patches = map originPkgs.fetchpatch remoteNixpkgsPatches ++ localNixpkgsPatches;
+        postPatch = ''
+          patch=$(printf '%s\n' ${builtins.concatStringsSep " "
+             (map (p: p.sha256) remoteNixpkgsPatches ++ localNixpkgsPatches)} |
+            sort | sha256sum | cut -c -7)
+          echo "-patch-$patch" >.version-suffix
+        '';
       };
-      pkgs = import nixpkgsPath {
+      profile = "/nix/var/nix/profiles/system";
+      inherit (inputs.nixpkgs) lib;
+      #nixosSystem = lib.nixosSystem;
+      nixosSystem = import (nixpkgsPath + "/nixos/lib/eval-config.nix");
+      forAllSystems = f: lib.genAttrs lib.systems.flakeExposed (system: f rec {
         inherit system;
-        config.allowUnfree = true; # For hplip
-        overlays = import nixpkgs/overlays.nix;
-      };
-      modules = [
-        {
-          config._module.args = {
-            inherit hostName inputs;
-            hosts = inputs.self.nixosConfigurations;
+        #pkgs = inputs.nixpkgs.legacyPackages.${system};
+        pkgs = import nixpkgsPath {
+          inherit system;
+          overlays = import nixpkgs/overlays.nix;
+        };
+      });
+    in
+    {
+      # nix -L build .#hello
+      packages = forAllSystems ({pkgs, ...}: pkgs);
+
+      # nix -L build .#nixosConfigurations.oignon.config.system.build.toplevel
+      # nix -L build .#nixosConfigurations.oignon.config.boot.kernelPackages.kernel.configfile
+      # nix -L build .#nixosConfigurations.oignon.pkgs.hello
+      # nix eval --raw .#nixosConfigurations.oignon.config.networking.nftables.rulese
+      nixosConfigurations = lib.genAttrs
+        (builtins.attrNames (lib.filterAttrs (_n: v: v == "directory") (builtins.readDir (inputs.self + "/hosts"))))
+        (hostName: nixosSystem {
+          system = null;
+          specialArgs = {
+            # Required to avoid infinite recursion
+            # when `inputs` is used in `imports`.
+            inherit inputs;
           };
-        }
-        (import (./hosts + "/${hostName}.nix"))
-        inputs.nixpkgs.nixosModules.notDetected
-        inputs.home-manager.nixosModules.home-manager
-        ({ pkgs, ... }: {
-          nix.registry.nixpkgs.flake = inputs.nixpkgs;
-          nix.package = pkgs.nixFlakes;
-          nix.extraOptions = "experimental-features = nix-command flakes";
-          #nixpkgs.overlays = import nixpkgs/overlays.nix;
-          /*
-          system.nixos.versionSuffix = ".${
-            lib.substring 0 8 (inputs.self.lastModifiedDate or inputs.self.lastModified)}.${
-            inputs.self.shortRev or "dirty"}";
-          system.nixos.revision = lib.mkIf (inputs.self ? rev) inputs.self.rev;
-          */
-          # Let 'nixos-version --json' know about the Git revision of this flake.
-          system.configurationRevision = lib.mkIf (inputs.self ? rev) inputs.self.rev;
-          /*
-          system.configurationRevision =
-            if inputs.self ? rev
-            then inputs.self.rev
-            else throw "Refusing to build from a dirty Git tree!";
-          */
-        })
+          modules = [
+            nixos/default.nix
+            (import (./hosts + "/${hostName}.nix"))
+            {
+              _module.args = {
+                inherit hostName;
+                hosts = inputs.self.nixosConfigurations;
+                host = inputs.self.nixosConfigurations.${hostName}._module.args;
+              };
+              nixpkgs.overlays = import nixpkgs/overlays.nix;
+              nixpkgs.config.allowUnfreePredicate = pkg: builtins.elem (lib.getName pkg) [ "hplip" "geogebra" ];
+            }
+            inputs.home-manager.nixosModules.home-manager
+            {
+              home-manager.useGlobalPkgs = true;
+              home-manager.useUserPackages = true;
+              home-manager.verbose = true;
+              home-manager.backupFileExtension = null;
+              home-manager.extraSpecialArgs = {
+                inherit hostName inputs;
+              };
+            }
+          ];
+        });
+
+      # nix -L develop  or  direnv allow
+      devShell = forAllSystems ({ pkgs, system, ... }: pkgs.callPackage ./shell.nix
         {
-          home-manager.useGlobalPkgs = true;
-          home-manager.useUserPackages = true;
-          home-manager.verbose = true;
-          home-manager.backupFileExtension = null;
-          home-manager.extraSpecialArgs = {
-            inherit hostName inputs;
+          inherit pkgs inputs system nixpkgsPath;
+          inherit (inputs.self.checks.${system}.pre-commit-check) shellHook;
+        });
+
+      # nix -L run .#oignon.switch
+      apps = forAllSystems ({ pkgs, system, ... }:
+        with builtins;
+        mapAttrs
+          (hostName: { config, ... }:
+            let
+              inherit (config.system) build;
+              target = "\"\${TARGET:-root@${config.networking.hostName}.${config.networking.domain}}\"";
+              scriptApp = scriptName: ps: script: {
+                type = "app";
+                program = (pkgs.writeShellScript "${hostName}-${scriptName}" ''
+                  export PATH="${lib.makeBinPath ([ pkgs.coreutils ] ++ ps)}:$PATH"
+                  set -eux
+                  ${script}
+                '').outPath;
+              };
+            in
+            {
+              # Example: nix run .#aubergine.switch
+              "switch" = scriptApp "switch" [ ] ''
+                shopt -s globstar
+
+                chmod -R g-rwx,o-rwx **/*.gpg
+                trap 'git reset **/*.gpg' EXIT
+                git rm -rf --cached --ignore-unmatch **/*.gpg # prevent copying to /nix/store
+
+                nix-store --add-root hosts/${hostName}.nixpkgs --indirect --realise ${nixpkgsPath}
+                nix-store --add-root hosts/${hostName}.root --indirect --realise ${build.toplevel}
+
+                nix copy --to ssh://${target}${lib.optionalString config.install.substituteOnDestination " --substitute-on-destination"} ${build.toplevel}
+
+                if ssh ${target} set -x ';' \
+                  systemctl reset-failed nixos-fallback '2>/dev/null' ';' \
+                  test "''${NO_NIXOS_FALLBACK:+set}" '||' \
+                  systemd-run -u nixos-fallback --description=nixos-fallback /bin/sh -xc '''\'''
+                    PATH=${with pkgs; lib.makeBinPath [ coreutils nix systemd ]}
+                    sleep $((10 * 60))
+                    ${profile}/bin/switch-to-configuration switch
+                    systemctl reboot
+                  '\'''' '&&' \
+                  ${build.toplevel}/bin/switch-to-configuration test
+                then
+                  ssh ${target} -o ControlPath=none set -x ';' \
+                    systemctl stop nixos-fallback.service ';' \
+                    nix-env --profile ${profile} --set '${build.toplevel}' ';' \
+                    ${build.toplevel}/bin/switch-to-configuration boot '&&' \
+                    nix-env --delete-generations 7d --profile ${profile}
+                else
+                  tput rev
+                  echo WARNING: switch-to-configuration was not registered at boot
+                  tput sgr0
+                  ssh ${target} -o ControlPath=none set -x ';' \
+                    systemctl stop nixos-fallback.service
+                  false
+                fi
+              '';
+            })
+          inputs.self.nixosConfigurations);
+
+      # nix flake check
+      checks = forAllSystems (args: with args; {
+        pre-commit-check = inputs.pre-commit-hooks.lib.${system}.run {
+          src = inputs.self;
+          hooks = {
+            nixpkgs-fmt.enable = true;
+          };
+        };
+      });
+
+      # nix fmt
+      formatter = forAllSystems ({ pkgs, ... }:
+        inputs.nix-formatter-pack.lib.mkFormatter {
+          inherit pkgs;
+          config = {
+            tools = {
+              deadnix.enable = true;
+              nixpkgs-fmt.enable = true;
+              statix.enable = true;
+            };
           };
         }
-      ];
-    });
-  } //
-  inputs.flake-utils.lib.eachDefaultSystem (system:
-    #let pkgs = inputs.nixpkgs.legacyPackages.${system}; in
-    let
-    pkgs = import nixpkgsPath {
-      inherit system;
-      config = {}; # Make the config pure, ignoring user's config.
-      overlays = import nixpkgs/overlays.nix;
-    }; in {
-      devShell = import ./shell.nix { inherit pkgs inputs system; };
-    }
-  );
+      );
+    };
 }