pumpkin: lanzaboote: enable SecureBoot
[julm/julm-nix.git] / home-manager / profiles / mpv.nix
index cd68c8988bfb1b2393268c2679aef84d3cc1f97c..906569bbdfb180b18757bdc96bfb1e8e352e6109 100644 (file)
@@ -2,10 +2,12 @@
 {
   programs.mpv = {
     enable = true;
+    # TipNote: Use mpv --input-test --force-window --idle to get the key names.
     bindings = {
       # Volume normalization
       # See https://github.com/mpv-player/mpv/issues/3979
-      "Alt+a" = ''cycle-values af "loudnorm=I=-25:TP=-1.5:LRA=1:linear=false" "dynaudnorm=framelen=100:gausssize=10:coupling=1:peak=0.58" "speechnorm" ""'';
+      "Alt+a" =
+        ''cycle-values af "loudnorm=I=-25:TP=-1.5:LRA=1:linear=false" "dynaudnorm=framelen=100:gausssize=10:coupling=1:peak=0.58" "speechnorm" ""'';
       "Alt+f" = "cycle video-unscaled";
 
       # Show all chapters (like a right-clic on |<< or >>|)
@@ -18,6 +20,7 @@
       "ESC" = "quit-watch-later";
       "Q" = "quit";
       "ENTER" = "playlist-next force";
+      "KP_ENTER" = "playlist-next force";
 
       "Alt+BS" = "playlist-remove current";
     };
@@ -53,6 +56,8 @@
       screenshot-avif-opts = "crf=24,aq-mode=complexity";
       screenshot-high-bit-depth = "yes";
       screenshot-tag-colorspace = "yes";
+
+      osd-font-size = 24;
     };
     profiles = {
       "extension.gif" = {
@@ -60,4 +65,5 @@
       };
     };
   };
+  xdg.configFile."mpv/scripts/history.lua".source = mpv/scripts/history.lua;
 }