{
programs.mpv = {
enable = true;
+ # TipNote: Use mpv --input-test --force-window --idle to get the key names.
bindings = {
# Volume normalization
# See https://github.com/mpv-player/mpv/issues/3979
- "Alt+a" = ''cycle-values af "loudnorm=I=-25:TP=-1.5:LRA=1:linear=false" "dynaudnorm=framelen=100:gausssize=10:coupling=1:peak=0.58" "speechnorm" ""'';
+ "Alt+a" =
+ ''cycle-values af "loudnorm=I=-25:TP=-1.5:LRA=1:linear=false" "dynaudnorm=framelen=100:gausssize=10:coupling=1:peak=0.58" "speechnorm" ""'';
"Alt+f" = "cycle video-unscaled";
# Show all chapters (like a right-clic on |<< or >>|)
"ESC" = "quit-watch-later";
"Q" = "quit";
"ENTER" = "playlist-next force";
+ "KP_ENTER" = "playlist-next force";
"Alt+BS" = "playlist-remove current";
};
screenshot-avif-opts = "crf=24,aq-mode=complexity";
screenshot-high-bit-depth = "yes";
screenshot-tag-colorspace = "yes";
+
+ osd-font-size = 24;
};
profiles = {
"extension.gif" = {
};
};
};
+ xdg.configFile."mpv/scripts/history.lua".source = mpv/scripts/history.lua;
}