-{ lib, config, ... }:
+{
+ pkgs,
+ lib,
+ config,
+ ...
+}:
{
networking = {
networkmanager.dns = lib.mkForce "none";
};
timeout = 5000;
use_syslog = true;
+ blocked_names = {
+ blocked_names_file = pkgs.writeText "dnscrypt-proxy2-blocked_names_file" ''
+ *.local
+ *.sp
+ '';
+ #log_file = 'dnscrypt-blacklist-domains.log'
+ #log_format = 'tsv'
+ };
};
};
networking.nftables.ruleset = ''