sourcephile.fr: nebula: open HTTP output
[julm/julm-nix.git] / nixos / profiles / dnscrypt-proxy2.nix
index 43fc3891c30d3f396e0f55f2fda32a2e7cf36c1c..f07f3b71f8d6eb4a9a47f4fc60ea196f68cef239 100644 (file)
@@ -1,4 +1,9 @@
-{ lib, config, ... }:
+{
+  pkgs,
+  lib,
+  config,
+  ...
+}:
 {
   networking = {
     networkmanager.dns = lib.mkForce "none";
       };
       timeout = 5000;
       use_syslog = true;
+      blocked_names = {
+        blocked_names_file = pkgs.writeText "dnscrypt-proxy2-blocked_names_file" ''
+          *.local
+          *.sp
+        '';
+        #log_file = 'dnscrypt-blacklist-domains.log'
+        #log_format = 'tsv'
+      };
     };
   };
   networking.nftables.ruleset = ''